Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Running CSiBridge 2015 (v17) using a CSiBridge 2016 (v18)   licenselicense

Info

PLEASE NOTE: Only the latest version of CSiBridge 2015 (v17.3.0 RMS 8.6) will work with the CSiBridge 2016 license. This new version of Please email support (support@csiamerica.com) to download CSiBridge 2015 (v17.3.0 RMS 8.6) can be downloaded from Customer Support Portal (do not download it . This version is not available for download from the CSI Installation Wizard). Please uninstall your current CSiBridge 2015 before installing the new CSiBridge 2015 (v17.3.0 RMS 8.6). CSiBridge 2015 v17.3.0 RMS 8.6 is is identical to CSiBridge 2015 v17.3.0 except for the update to the licensing.

 

When running CSiBridge 2015 (v17) using a CSiBridge 2016 (v18), a level.txt is not required. 

...

  • Network license – The CSiBridge 2015 (v17) license will reside on the server for a network license. The level.txt file will reside on the client machine, copied into the CSiBridge 2014 folder which contains the CSiBridge.exe.

ETABS Examples

Running ETABS

...

v17 using an ETABS v18 license

When running ETABS v17 using an ETABS v18 license, the level.txt file created will contain one line with the following information:

  • Line 1: [Product Level] [Product Version]

Product level should be the level of the current license, for example: 'PLUS', 'NONLINEAR', or 'ULTIMATE', etc. See level.txt for a list of levels for each CSI program. Product version should be the version number of the current license. 

For example:

ULTIMATE 18 

Please see your licensing option below for the appropriate locations for where the level.txt and activated license should reside: 

  • Standalone license – 
    • Web-Activated License:
      • License file
        • The ETABS v18 license must be activated on this machine. 
        • Copy the "lservrc" file from Computers and Structures > ETABS 18 folder into the Computers and Structures > ETABS 17 folder. 
        • The "lservrc" file must be copied each time the v18 license is activated on this machine. Once v18 has been deactivated from this machine, the ETABS v17 product will also stop working. 
      • Level.txt: The level.txt file will also be copied into the ETABS 17 folder (Computers and Structures > ETABS 17)
    • Manual License (such as license locked to USB key):
      • License file: Copy the ETABS v18 "lservrc" file into the Computers and Structures > ETABS 17 folder (from Computers and Structures > ETABS 18 folder). 
      • Level.txt: The level.txt file will also be copied into the ETABS 17 folder (Computers and Structures > ETABS 17)
  • Network license – The ETABS v18 license will reside on the server for a network license. The level.txt file will reside on the client machine, copied into the ETABS 17 folder which contains the ETABS.exe.

Running ETABS 2016 using an ETABS 17 license

Info

PLEASE NOTE: Only the latest version of ETABS 2016 (v16.2.2) will work with the ETABS v17 license. Please email support (support@csiamerica.com) to download ETABS v16.2.2. This version is not available for download from the CSI Installation Wizard. ETABS v16.2.2 is functionally identical to ETABS v16.2.1 except for the update to the licensing. Model files are interchangeable between the two versions, and both versions produce identical results to within the numerical accuracy of the computer.

When running ETABS 2016 using a ETABS 17 license, a level.txt is not required. 

Please see your licensing option below for the appropriate locations for where the activated license should reside: 

  • Standalone license – 
    • License file: The ETABS v17 license must be activated on this machine. Copy the "lservrc" file from Computers and Structures > ETABS 17 folder into the Computers and Structures > ETABS 2016 folder. The "lservrc" file must be copied each time the ETABS v17 license is activated on this machine. Once the ETABS v17 license has been deactivated from this machine, ETABS 2016 product will also stop working. 
  • Network license – The ETABS v17 license will reside on the server for a network license. Once the client machines have been updated to the correct version of ETABS 2016 (v16.2.2), the client machine will automatically pick up the ETABS v17 network license. 

Running ETABS 2015 using an ETABS 2016 license

Info

PLEASE NOTE: Only the latest version of ETABS 2015 (v15.2.3) will work with the ETABS 2016 license. This new version of Please email support (support@csiamerica.com ) to download ETABS 2015 (v15.2.3) can be downloaded from Customer Support Portal (it . This version is not available for download from the CSI Installation Wizard). ETABS v15.2.3 is functionally identical to ETABS v15.2.2 except for the update to the licensing. Model files are interchangeable between the two versions, and both versions produce identical results to within the numerical accuracy of the computer.

 

When running ETABS 2015 using a ETABS 2016 license, a level.txt is not required. 

...

Info

PLEASE NOTE: Only the latest version of SAFE 2014 (v14.2.1) will work with the SAFE 2016 license. This new version of SAFE 2014 (v14.2.1) can be downloaded from here (it is not available for download from the CSI Installation Wizard). SAFE v14.2.1 is functionally identical to SAFE v14.2.0 except for the update to the licensing. Model files are interchangeable between the two versions, and both versions produce identical results to within the numerical accuracy of the computer.

 

When running SAFE 2014 using a SAFE 2016 license, a level.txt is not required. 

...

  • Network license – The SAFE 2016 license will reside on the server for a network license. Once the client machines have been updated to the correct version of SAFE 2014 (v14.2.1), the client machine will automatically pick up the SAFE 2014 network license. 

SAP2000 Examples

Running SAP2000 v20 using a SAP2000 v21 license

Info

PLEASE NOTE: Only the latest version of SAP2000 v20.2.1 will work with the SAP2000 v18 license. Please email support (support@csiamerica.com ) to download SAP2000 v20.2.1. This version is not available for download from the CSI Installation Wizard. Please uninstall your current SAP2000 v20 before installing the new v20.2.1. SAP2000 v20.2.1 is is identical to SAP2000 v20.2.0 except for the update to the licensing.

When running SAP2000 v20 using a SAP2000 v21 license, a level.txt is not required. 

Please see your licensing option below for the appropriate locations for where the activated license should reside: 

  • Standalone license – 
    • License file: The SAP2000 v21 license must be activated on this machine. Copy the "lservrc" file from Computers and Structures > SAP2000 21 folder into the Computers and Structures > SAP2000 20 folder. The "lservrc" file must be copied each time the v21 license is activated on this machine. Once v21 has been deactivated from this machine, SAP2000 v20 will also stop working. 
  • Network license – The SAP2000 v21 license will reside on the server for a network license. Once the client machines have been updated to the correct version of SAP2000 v20.2.1, the client machine will automatically pick up the SAP2000 v21 network license. 

Running SAP2000 v19 using a SAP2000 v20 license

...

Info

PLEASE NOTE: Only the latest version of SAP2000 v17.3.0 RMS 8.6 will work with the SAP2000 v18 license. This new version of Please email support (support@csiamerica.com ) to download SAP2000 v17.3.0 RMS 8.6 can be downloaded from Customer Support Portal (do not download it from the CSI Installation Wizard). This version is not available for download from the CSI Installation Wizard. Please uninstall your current SAP2000 v17 before installing the new v17.3.0 RMS 8.6. SAP2000 v17.3.0 RMS 8.6 is is identical to SAP2000 v17.3.0 except for the update to the licensing.

 

When running SAP2000 v17 using a SAP2000 v18 license, a level.txt is not required. 

...

Hidden content

To use SAP2000 V15 license to run SAP2000 V14 with the add-on module license (Bridge, Staged Construction, Off-Shore), the SAP2000 V14.2.5 program installation and the SAP2000 V15 Ultimate license are required.

Related Incident:

  • Incident
    no53478
    commentRunning SAP2000 v14 with Off Shore using SAP2000 v15 network license

Related Email:

  • Email
    date11/14/2012
    subjectLevel.txt notes
    fromKim
    commentLevel.txt notes on SAP2000 v14 using v15 license
    tofromMikeKim
    id9896232
    toMike

See Also