
Training Guide
Modeling, Analysis, and Design of Pipe Rack

Structures Using SAP2000
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Using the attached pdf drawings (PR1.pdf and PR2.pdf), this tutorial will show you how to 

model, analyze and design the 6 bay pipe rack structure shown below supporting air 

cooled heat exchangers. This is an extruded view of the structure, color coded by 

sections.



3

Click new model button    or File>New to begin. The first screen that appears enables you to 
select units and offers a number of template options. In most cases you will want to define grids. 
Select Kip, ft, F units and click ‘Grid only’. Input uniform spaced grid lines and spacing shown 
below right, including the 7’6” architectural units in Y direction grid spacing then press OK. You 
can input using architectural units and tab or press OK for SAP2000 to convert to current units
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By default, you will see a split-screen view. If you click the planar view on the left, you will see a blue 
outline on the 3D model highlighting the planar view location. Press the down arrow to move to plan 
view Z = 0

Dark blue border 

indicates that this 

window is the ‘active’

view

You can change 

units at any time 

here

Press 

down arrow
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Next, double click any gridline with your mouse to display the Define grid screen below. Type in values 
in Z grid direction as shown below for main beam locations shown on the PR2.pdf drawing and press 
OK

Adjust bubble size 

here if grid 

bubbles appear 

too large or too 

small

When ‘Glue to Grid lines’ option is 

activated, when modifying gridlines, all 

elements associated with that grid will 

stretch or shrink with the gridline itself. 

Leave unchecked for this exercise
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Click yz button   to switch planar view to elevation and press arrows   to move to X = 0 

Y-Z plane as shown below
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Before we import our sections, use the main menu to review the Define>Materials where we see two 
default materials, 4000 psi concrete material and A992 steel material. You can add new materials using 
the ‘Add new material quick’ button to select from a material library, or use the ‘Add New Material’
button to add a material not found in the libraries. In a concrete structure, typically multiple concrete 
materials need to be used for different strengths and weights. 
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Cancel out of the Define Materials dialogue to accept the default materials, then go to Define>Section 
properties>Frame sections where you will see the screen on the bottom left. For standard steel 
sections and joists, you use the ‘Import New Property’ button. First, click I/Wide Flange button to 

import those sections.
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In order to utilize the latest AISC sections, go to the directory where SAP2000 is installed and click the 
SECTIONS8.PRO file. As you can see, SAP2000 offers libraries for several international steel shapes, 
as well as aluminum shapes and a joist library. After clicking to open this file, you will see a dialogue 
like the one on the bottom right. Use your mouse and drag to select all W sections from W8 through 
W21’s and press OK
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Press OK again to add these sections to the working list. Next, click ‘Import New 

Property’ button and click the ‘Tee’ button to view the Tee sections, select WT4X9 and 

WT4X12 and press OK twice to add these sections to the working list.
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As a learning exercise, click ‘Add New Property’ button, then click I/Wide Flange. As you can see on 
the right, you can change dimensions to define a nonstandard steel section and even change material 
to concrete. Use of the Add options are needed to add/define concrete sections, nonstandard steel 
sections, nonprismatic steel shapes, and auto-select lists. Cancel out of this Add I/Wide Flange screen
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As another learning exercise, click ‘Add new property’ again, change Frame Section Property type to ‘Built-Up 
Steel’, can click Cover Plated I as shown below. Here you can quickly add top and/or bottom cover plates to 
Wide flange sections which are used for design as well as analysis. Cancel this as we are using only standard 
sections for this exercise, although it’s useful to know this tool is available for design.
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Click ‘Add new property’ again and change Frame section property type to ‘Other’. Here is where you can 
define general sections, nonprismatic sections, or access the section designer. Click ‘Section Designer’
button, and when you select a ‘Base material’, you have the option to include it in the design. Click ‘Section 
designer’ button shown in 2nd screen shot below
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Use the shape options below to create built-up combined sections. Use reshaper tool     and right click the 
individual sections to move them, rotate, or modify dimensions to help you combine them. SAP2000 
automatically calculates combined areas, moments of inertia, etc. and uses this combined section not only 
for analysis, but also for design. Cancel out and return to Define frame section property dialogue to 
continue.



15

The drawings call for W14 columns. The exact section is not specified which means that the engineer needs 
to size the most economical W14 section which meets design requirements. We will do this by defining and 
assigning Auto select lists which SAP2000 will use to optimize for lightest section during design. We will 
define separate Auto select lists for W14’s, W16’s, W18’s and W21’s. Click ‘Add New Property’ button, and 
using frame section type Steel, click Auto Select List. Change the Auto Section Name to AUTO14 in order to 
help us remember, then select all W14 sections as shown below, then click Add-> to add them to the Auto 
Selections list
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Change the Auto Section Name as shown below, select all the W16 sections on the left, then press 
Add-> to place them on the right, the press OK to accept. Repeat this process to create an auto select 
list for the W18’s, then one more for the W21’s. Don’t forget to name each Auto Section list differently 
(AUTO14, AUTO16, AUTO18, AUTO21), then press OK until you return to the main menu screen 
shown below right
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Click the ‘Draw Frame/Cable object’ button    as shown, click Section in the floating properties box to 
select AUTO14, moment release continuous, then in Y-Z window X= 0 ft, click once on the bottom left as 
shown and then click once more at the top. Instead of assigning an individual section, for example 
W14X90 or another section, the W14 Auto Select list enables SAP2000 to optimize to choose the lightest 
section in that list which meets design code and user specified drift requirements.
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After clicking the top to complete drawing the column, right-click to move your cursor and 

draw another column along 5A. Click zoom-out button    to view grid labels

Draw column from 

bottom to top along 

grid 5A
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This is what your model should look like. Next, we will draw the W21 moment connected continuous 
beam as per the drawing. Click the Section and select AUTO21 and draw a beam left to right as 
shown. SAP2000 will internally create a joint at the beam/column intersection in order to transfer shear 
and moments, but SAP will then reformulate the results to report and design the columns using the 
length which was used to draw them (40 ft. tall columns)

Coordinates of 

mouse location are 

always shown here
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Right click to move your cursor, change section to AUTO18 as shown below, and draw 

another beam as shown. As you can see, the grids help you snap to draw
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Change the Section to AUTO16, and since this beam is not designated M.C., the moment 

release needs to be changed to Pinned. Draw the third beam as shown.
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Change Section to AUTO14, keep the Moment releases as Pinned, and draw the 4th beam as shown 
along the top gridline just above the beam which was previously drawn
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Press the Esc key on your keyboard or click the select button as shown below left in order to go into Select 
mode. While holding down the mouse key, drag to window a box around the bottom two joints to select them. 
Next, go to Assign menu>Joint>Restraints and add pin restraints as shown below. Press OK
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Click anywhere inside the 2D planar view window on the left to make sure it’s the ‘active’

window, then click ‘set display options’ button     at the top, checkbox/activate the 

Releases option as shown and press OK in order to graphically view moment releases
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Next, click set display options button again, but this time uncheck the Releases and activate the 
Extrude view option as shown to create a rendered view. Note the option below to ‘Apply to All 
Windows’. Each display option can apply to the active window only or to all windows. In this example, 
we will apply only to our active planar view window. 
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We will next adjust the beams to be dimensioned to top of steel (T.O.S. in drawing). Holding 

down the mouse key, drag your mouse right to left to window intersect the 4 beams. Dragging 

right to left is a convenient method to select elements and joints which are intersected. 
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Next, use Assign menu>Frame>Insertion Point to assign the ‘cardinal point’ type of connection. You 
can press F1 with this dialogue open to read the Help menu for more information. In this case, we want 
top of steel, so select #8, top center and press OK. Based on frame section size and type of insertion 
point, SAP2000 moves the frame and adds a rigid link to account for the offset/eccentricity which will 
change analysis results compared to centerline connection. You can toggle back and forth with undo/redo 
in extruded view to visualize what SAP2000 is doing. Next, use the ‘set display options’ to deactivate the 
extruded view for the time being. You may have to press the F4 key on your keyboard to clear the screen 
if the insertion point assignments are in view after deactivating extruded view

After assigning insertion point, 

use Set display options to 

uncheck Extruded view
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Per the drawings, there are two 24” diameter pipe loads dimensioned from the left side beam column 
intersection on the W18 beam, one 15’ feet from the left beam/column intersection and the other 3’ away 
in the Y direction from the centerline of the first pipe. Left click the AUTO18 beam and use Assign>Frame 
loads>Point. With this option, you can assign one or more point loads along selected frames based on 
percentage or actual distances from I to J end using current units. Click + sign to add additional load 
pattern for pipe loads as shown. Name the Load Pattern “PIPE”, type DEAD, Self weight multiplier of 0 to 
avoid double counting self-weight of the structure, then press ‘Add new load pattern’ to add it to the list 
and press OK. Alternatively, we could have used Define>Load Patterns beforehand

Click + sign to 

define additional 

load patterns

Self Weight 

multiplier zero 

for PIPE load
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Switch Load Pattern to PIPE, select ‘Absolute distance’ from End I with Kip, ft units and assign a 2.5 
Kip load at 15 ft. and 18 ft. as shown below in the gravity direction and press OK.



Right click any element or any joint to review or modify information. Here you can modify any 
parameter on the form using any of the tabs by double clicking with your left mouse key in the white 
area. Go ahead and press OK or Cancel without modifying anything at this time.
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We will use a different joint load assignment method for the load assignment on the W16 beam. Per 
the drawing, the pipe load is 2’6” away from the right side intersection of the W16 beam and the 
column, so click the ‘Draw special joint’ button     and type -2’6” in the Y direction as shown. Next, click 
the intersection of the W16 beam and column as shown below with the grid point bubble to add a joint. 
The Draw special joint option will draw joints offset from wherever you mouse click. Since drawings 
often reference offset dimensions, this can be a useful option for assigning joint loads or to create 
joints in order to connect the dots to model frames. 

Click here to 

draw special 

joint
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Press select arrow or Esc key to go into select mode, then click the joint to select and Assign>Joint 
load>Forces. Change load pattern name to PIPE or add a new load pattern if you wish to create 
separate load cases for different size pipe loads, then assign a 3 Kip joint load in the –Z (gravity) 
direction and press OK. Press F4 to clear load assignment.
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Click ‘Select all’ button as shown, then from the main menu Edit>Replicate and type dx 20’ increment 6 to 
replicate the selected elements and joints 6 times at 20 ft. each in the X direction. As an exercise, click the 
‘Modify/Show Replicate Options button. Here you can pick and choose what you want to replicate what you 
don’t (load assignments, local axis rotation, restraints, etc). Cancel or Press OK on the Replicate Options to 
accept all, then press Ok on the Replicate screen
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This is what your model should now look like. Click once in the 3D view window to make it the ‘active’
window. Use ‘set display options’ to activate extruded view, click the zoom button    and hold down your 
mouse key to window into the area in the far X direction (see next page). 

In a real design, we would adjust the pipe loads to account for different tributary area load distribution, but 
for this example, we will leave all bays with the same pipe loads as assigned on the end frame. By selecting 
frames, users can Assign>Frame loads>Distributed or Assign>Frame>Fireproofing to assign other 
loads which we will ignore for this exercise

SAP2000 offers an automated 

feature to assign fire cladding weight 

which can save time compared to 

manual calculation and assignment 

of fire cladding
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If the extruded view does not appear, press F4 and try again. Next, we are going to learn how to rotate 
the local axis of frames. Left click the column shown below to select as shown below right and 
Assign>Frame>Local axes, type 90 degrees and press OK.
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If you zoom in on the extruded view, you can view how the local axis has been rotated. By rotating the 
local axis, you may activate the red/white/blue local axis arrows in the planar view. Local Axes 1, 2 
and 3 correspond to the arrow colors red, white and blue, just like the American flag. Frames, joints, 
links and area finite elements each have their own local axes which can be viewed anytime using the 
‘set display options’ dialogue. Press F4 to clear the arrows and press undo button to undo the rotation.
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Next we will draw the grating spans for the air coolers. Click anywhere in the left window to make it 
active, then press the xy button to switch to plan view. You may have to click the up/down arrows         in 
order to move XY plane to Z = 40 ft top level as shown. In order to view full 3D window, click once in the 
3D window to make it active, then press 3-d button or press F3 for full view 
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Press ‘Quick draw frame/cable element’ as shown, click to change section of W10X17 Pinned, hold down 
your left mouse and window around gridline 5 as shown. Repeat this draw procedure one-strip-at-a-time for 
grids 1 – 4 too. The quick draw frame element enables you to window around an area to draw multiple frames 
very quickly, but it divides each frame at visible gridlines. So each W10X17 beam is divided at each gridline B 
through F. Since the ‘Quick draw’ frame option draws and divides the frames at each grid intersection, we 
draw one strip at a time to avoid drawing beams along the Y direction at grid intersections.
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Next, we will replicate joints to make modeling of stitch bracing easier. In plan view, click each of the 4 
joints shown below left to select, then Edit>Replicate to replicate 24 times (increments) 5 ft. each in 
the X direction. Press OK
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Click ‘Draw frame/cable element’, change section to WT4X9 Pinned as shown and draw the stitch 
bracing by “connecting the dots” as shown below. Remember to right click in order to move your 
cursor while in draw mode. The additional joints which were not used to draw bracing will not affect the 
model at all since they are associated with a frame/beam element object.

This is how the stitch bracing should look 

according to the PR1.pdf drawing
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Next, go to Define menu>Section properties>Area properties to create a shell finite element for our grating. Change material to 

A992 steel and type .5” in the membrane and bending stiffness fields. Next, press the Set Modifiers button where we will zero out the 

weight and mass while minimizing the stiffness, since we do not want to consider the grating as part of our structural system, only a 

modeling tool to transfer area loads to beams while avoiding load distribution to bracing underneath. Type .01 in every field except 
Mass and Weight where you type 0 to zero out the weight and mass as we will assign grating self weight and live load manually 

based on vendor data and known loading.

Shell type area finite elements distribute loads only at meshed joint locations. We will not mesh this Grating shell at locations where 

there is bracing underneath to avoid distributing load to the bracing

If you are in ft. 

units, 5” will 

convert to ft 

units

Use .01 to reduce section properties and zero 

the weight and mass
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Click ‘Quick draw area element’ button as shown, making sure the section is the GRATING section we just 
defined and hold down your mouse and window around the entire top level in plan view as shown to draw 
grating. The Quick draw area element, like the quick draw frame tool, divides the elements at each visible 
grid intersection. Press Esc key on your keyboard or Select button to switch to select mode
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Use Select>Select>Properties>Area sections to select GRATING and click OK to select them. Next, 
use Edit >Edit areas>Divide areas and type in a 1 X 3 mesh as shown below in order to divide the mesh 
into thin strips forcing it to distribute load one-way and press OK. If we wanted the grating to distribute two-
way, or one-way in the Y direction, we would have meshed differently or not meshed at all. This exercise 
helps demonstrate how users can control load distribution. 
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Below is what your plan view should look like now. Next, window around the entire plan view to select 
area elements in order to assign loads. Don’t worry if you also select frame elements and joints along 
with the areas.

With SAP2000, you can assign area loads before or after meshing. SAP2000 keeps track of area load 
assignments no matter how the areas are meshed afterward.
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Go to Define>Load patterns and define load patterns (which used to be called ‘load cases’ in 
previous versions) as shown below and press OK. Earlier we added the PIPE load case while 
assigning loads. This is the more conventional way of defining load patterns. Careful not to have more 
than 1 load case with self weight multiplier of 1 or you will double count or triple count the self weight 
of the structure.
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Next, go to Assign>Assign area loads>Uniform (shell), change load pattern name to 
GRATINGLIVE and type 90psf in the load field and press OK. SAP2000 will automatically convert to 
current units. Click previous selection button to reselect and Assign> Assign area loads>Uniform 
(shell), change load pattern to GRATINGSELFWT enter 15psf and press OK. This is a faster, less 
error prone method of load distribution as compared to assigning the grating loads as distributed frame 
loads based on tributary area. Press F4 to clear screen of load assignments if the screen appears 
cluttered. Save model and name it SAPTutorial. It’s a good idea to save your model often

Press F4 to clear screen of clutter from assignments
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Next, we will add side beams and bracing, so we need to add gridlines to facilitate modeling. Click 
anywhere in your plan view window to make sure that it’s the active window and press xz button. You 
may need to use up/down arrow keys to move to Y=30 ft. Double click any gridline to display the 
Define grids dialogue
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Add gridlines in the Z direction for 13, 19, 25, and 31 feet as shown to facilitate drawing the new 
beams and bracing. SAP2000 will sort out the sequence when you press OK
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No sections were specified on the drawing for the side beams and bracing, so we will use W10X17 
beams and W8X21’s for the bracing. Alternatively, we could have assigned an Autoselect list in order 
to have the program optimize for lightest section. Click the ‘Quick draw frame’ option and window 
around the gridline at Z elevation 19 ft. per the drawing. This will draw 6 frames/beams inside the 
window area, dividing them at each visible gridline.
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Repeat this draw technique at elevations 25 ft and 31 ft. as well as at 13ft in the two bays between 5B 
and 5C and 5E and 5F. With gridlines so close together, it may be easier to toggle off your default 
‘snap to points and grid intersections’ button temporarily by clicking it.

Snap tools can be 

toggled on and off 

to help you more 

easily draw
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Click to activate snap tools for snap to ‘points and intersections’ as well as the ‘ends and midpoints’
snap tool just below it. Click ‘Draw frame/cable element’ button, change the section to W8X21 Pinned 
and draw bracing as shown below. SAP2000 will create joints internally to connect the bracing to the 
beams to transfer shear, but SAP’s object based modeling will reformulate the output in order to report 
and design the beams as they were drawn without dividing the beams into two pieces in the output. 

Both of these snap tools 

should be activated to 

enable us to snap to 

joints and midpoints

Both of these snap tools 

should be activated in order 

to snap to midpoints and grid 

intersections
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Next, we will select these newly drawn beams and braces in order to replicate them to the other side. Press 
Esc key or the select button to switch into Select mode, then use Select>Select>Properties>Frame 
sections and select W8X21 as shown. Press OK
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The first graphic shows the W8X21’s’s selected. Next, window around the area moving the mouse left to 
right as shown below in the bottom left in order to select the beams without selecting the columns. Note 
that this selection technique selects some additional joints, but replicating joints won’t hurt anything as 
along as the joints are associated with a frame and not disconnected out in space.
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Next, use Edit>Replicate in order to copy the selected beams and bracing to the other side, 1 
increment 30 ft. in the –Y direction (-30 dy) as shown below. Next, we will add an IBC2006 seismic 

load and a wind load in order to demonstrate SAP2000’s auto-lateral load generation.
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As an alternative to manually calculating seismic and wind loads applied as joint loads or distributed loads, 
SAP2000 offers options for automatic generation of wind and seismic loads per IBC, ASCE and other 
standards. Go to Define>Load patterns, add a load case named QX, type Quake, Auto lateral load 
IBC2006 as shown below and press ‘Add new load pattern’ button to add it, then press ‘Modify Lateral 
load pattern’ to specify IBC parameters. Select option to lookup Ss and S1 values based on zip code using 
79901 zip code below for El Paso, TX. Press OK until you return to the Define load pattern dialogue
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Next, add load pattern named WY type Wind using Auto Lateral load pattern ASCE 7-05 and press ‘Modify Lateral load 

pattern’ to specify parameters. Change the default to ‘Exposure from Frame and area objects’ Include Area objects which 
we will add later for the air cooler and include Frame objects (open structure). Wind direction angle 90 degrees (Y direction) 

for the wind load generation on the frame elements, 110 mph and press OK. Later we will assign wind load coefficients to 

area objects which simulate the dimensions of the air coolers
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Next, as a modeling technique we will add “dummy” area elements and joint loads to simulate air cooler 
wind exposure. Double click a grid to display Define grid dialogue and add Z grids at 50 ft and 60 ft. and an 
X grid at 19.9 ft. The purpose of the 19.9 X grid is to create aircooler areas for wind load that are 
disconnected from one another, as we will replicate them 20’ apart and keep them separate. Press OK to 
add the grids.

With new gridlines added
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Go to Define>Section Properties>Area sections and Add new section, name it AIRCOOLER, material 
A992, with both membrane and Bending thickness 1”. Next, click ‘Set Modifiers’ button and enter 0 for 
mass and weight as we will assign the aircooler weights later at joint locations

Type 1”

which will 

convert to ft 

units
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Switch your left side planar view to xz elevation view Y=0. Next click ‘Quick draw area’, change 
section to AIRCOOLER, and click just once in the upper left area shown below to the right of 1A. The 
addition of the 19.9 ft gridline keeps this area disconnected from the next bay by .1 ft. We will assume 
that the air cooler will catch wind load between 40’ and 50’ and transfer it to the structure below
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Click to select this AIRCOOLER area and Edit>Replicate as shown 30’ in the Y direction to copy it to 
the other side. Next, switch your planar view to yz with X=0, click ‘Draw rectangular area element’
and then click once on upper left corner and drag it down to the right corner as shown below. This 
draws 1 area element without dividing it at every visible gridline

Click here and 

hold mouse key 

to drag to bottom 

right corner
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Use ‘Set display option’ to activate ‘Fill objects’ view and press OK. The color of the area objects 
indicate the local 3 axis. The pink color shown below right indicates that the local +3 direction for that 
area element is = +X direction since +3 is perpendicular outward and away from the red face whereas 
-3 is outward and away from the pink face. When assigning area wind load coefficients, you must 
know the local 3 direction. Select the area shown below in pink and replicate it 19.9 ft one time in the X 
direction to complete the air cooler box
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Next go to Select menu>Select>Properties>Area properties and click AIRCOOLER to 

select. Then Edit>Replicate the selected areas 20ft in the X direction 5 times/increments. 
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Next, switch to xy plan view Z=50 ft. Here click ‘draw special joint’ to add joints at the aircooler CG to 
assign weight. Input Offset X = 10’ and Offset Z = .3 ft as shown, then click the intersection of gridlines 
3 and A, and click refresh to view the joint. By default, SAP2000 enables you to view any object .83 ft 
on either side of the 2D planar view. You can change the .83 ft. viewing tolerance default with the 
Options menu>Dimensions/Tolerances. Next, press Esc key to go into select mode, select the new 
joint, and replicate it 20 ft. in the X direction 5 times/increments

Replicate the joint 5 times

Draw special joint

Refresh
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Still in xy plan view, zoom in      and zoom out    to select the 4 bottom corner joints of the aircooler elements 
plus the CG joint (5 joints per bay) where we will later assign the aircooler weight at the CG joint location. Then 
Assign>Joint>Constraints, body type to rigidly link the CG joint to the 4 corners one bay at a time. The body 
constraint rigidly links the joints with consideration of the moments from the offset distance. You need to assign 
a joint body constraint to the CG joint of each aircooler “box” in each bay. You will need to zoom in to each of 
the 6 bays one at a time, because the edge joints are so close together. You will need to assign a different joint 
body constraint for each bay which means that you will have a BODY1, BODY2, etc. 

Add a different BODY 

constraint to each 5 joints 

(4 bottom corners of air 

cooler + 1 CG joint) for 

each bay



65

Left click to select each of the 6 aircooler CG load joints as shown on bottom left, then Assign>Joint 
loads>forces 210 kips in the –Z direction under Load pattern AIRCOOLER as shown on bottom right. 
According to the PR2.pdf drawing, each aircooler should be considered 350psf. Given that each bay is 
20’ X 30’, that makes the weight of each air cooler 210 kips, which we lump at the CG of each air 
cooler
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Next step is to link the aircoolers to the structure. You can link the aircooler to the structure using frame elements (W14 or 

whatever section) or link it rigidly with joint constraints. In this exercise, we will assume that the aircooler manufacturer has 

already designed the legs and will deliver each aircooler as a pre-designed module. Therefore, we will link  each cooler to the 

structure using an alternative to the joint constraint method we used before using a “DUMMYLINK” zero weight frame/column 
element. Go to Define>Section properties>Frame sections and click ‘Add new property’. Change frame property section type to 

Concrete, then click circular. Change Material to A992 steel, .5 ft. diameter, then click ‘Set modifiers’ button. Enter 0 for Mass 

and Weight which we lump at the CG joint, and enter 5 multiplier for area and EI as shown below to define a stiff,  but not  

completely rigid zero weight section. Click OK until the section is added to the working list

Pay no 

attention to 

the rebars in 

the graphics. 

It’s all steel
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Go to xz planar view Y=0 and press F4 to clear the screen. Click ‘draw frame/cable element’ then 
change section to ‘DUMMYLINK’ frame section which we just defined. You will need to zoom in tight in 
order to draw the frames to the same joint shown below, connecting the AIRCOOLER joints to 
structure. Both (2) air cooler joints will need to be attached to the structure in this fashion. In this 
screenshot, only 1 of the two are attached.

Two DUMMYLINK 

columns connect at the 

same joint where there is 

a W14 column below
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As you can see, you will need to connect both closely spaced DUMMYLINK columns to the same 
structural joint below where the W14 column is located. After finishing this, press Esc key or Select 
arrow to switch to select mode. Draw these aircooler DUMMYLINK columns for each bay in xz view 
Y=0.

Both joints from 

aircooler above 

connect to the same 

column joint here

Careful as joints are 

spaced close 

together
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Use Select menu>Select to select by frame property “DUMMYLINK” to select these newly drawn columns. 
Next, use Edit>Replicate to copy 30 ft in the Y direction 1 time/increment in order to copy to the other side. 
Next, go to xz elevation view Y=0 and select the AIRCOOLER areas in that view along gridline 1 as shown 
below by clicking them.

Selected 

areas



70

The red face of the AIRCOOLER area elements in this plane tells us that the local perpendicular axis of the selected elements 

is (+3) is = -Y according to the way we modeled these area shell elements. Use Assign>Area loads>Wind pressure 

coefficients (Shell). Since we are assigning a windward load in the +Y direction to areas which have a local axis of +3 = -Y, we 

will need to assign a windward Cp of -.8 (which is +Y direction) to area elements in XZ plane Y=0. Area wind pressure 
coefficients are relative to the local 3 direction of each area. Press F4 on the keyboard to clear this load assignment. 

Next, use arrow keys to move to XZ plane Y=30’ to select aircooler areas for leeward wind assignment
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In X-Z, Y=30 ft. view, select the areas along gridline 5 in order to assign the leeward side of WY load case. Assign>area 

loads>wind pressure coefficients as shown below on bottom right using Cp of -.5 in the “other” (leeward) direction for the 

same wind load case. You can use ‘Set display options’ to check local axes of area elements. Blue arrows = +3 area/shell 

axis ASCE wind load generation on frames is automatic, but wind loads on area elements require an additional assignment. 

With this in mind, we could have also modeled pipes and/or vessels using frame elements (with or without zero weight 
sections) and had SAP2000 automatically generate wind load for them too.

Leeward side of the 

aircooler for WY 

load case, areas 

selected in XZ  

plane Y = 30 ft.
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For auto lateral load calculation of static equivalent IBC seismic loads, SAP2000 has to determine 
fundamental periods of the structure, which means that a dynamic modal analysis will be performed. 
Typically you will want to modify the mass model using Define>Mass model. SAP2000 offers an option to 
convert load cases into mass. Please specify your mass model as shown below and press OK
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Since this design will be performed using 2005 AISC code, we will need to generate “notional” lateral loads, 
which is a new AISC code requirement to account for out-of-plumbness. SAP2000 offers the capability to 
automatically generate lateral notional loads, but users must specify the gravity loads to be used. Add a 
load pattern named NotDeadX, type Notional (you may have to click ‘Other’ before notional type appears) 
and press ‘Add new load pattern button’ then press ‘modify lateral load pattern to specify parameters. For 
this example, let’s generate notional loads based on DEAD and AIRCOOLER load patterns since these are 
the two most significant gravity loads in this model



74

Below are the auto notional load patterns named NotDeadY (notional Y direction DEAD case), 
NotACoolX and NotACoolY for the air cooler notional loads. SAP2000 will automatically generate the 
notional lateral loads at each level
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Next we will specify design parameters. For this example we will use the 2005 AISC Direct analysis 
method which enables us to avoid the time consuming task of determining K factors from alignment 
charts while often times achieving more economical designs compared to ELM. Go to Design>Steel 
frame design>View/Revise overwrites and input design code and other parameters as shown, OMF 
Framing type, Tau-B variable Direct analysis. You can select individual frame elements and assign 
design parameters using Design>Steel frame design>View/Revise overwrites. There is an excellent 
steel frame design manual which installs with each version of SAP2000 V12 under the ‘Manuals’
subdirectory.
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Next we will go to Define>Load combinations. Users can define their own load combos, or they can 
let SAP2000 create factored load combos for them based on the design code and load type. Click the 
‘Default design combos’ option then select Steel frame design and press OK. This automatically 
generate factored load combos which can be reviewed or modified. Alternatively, users can create 
their own load combo spreadsheets in Excel and import. 

You will use this 

‘Convert combos to 

Nonlinear cases’

button in the next 

slide
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The 2005 AISC code requires either a nonlinear P-delta analysis, or a time consuming 1st order amplification procedure which has 
a number of limitations in its permitted use. For this exercise we will perform a P-delta analysis. Since P-delta is a nonlinear 

analysis, loads cannot be superimposed. This same concern is also true whenever modeling nonlinear tension only bracing and 

other NL applications. SAP2000 enables you to convert factored load combos to NL  cases considering P-delta by clicking the 

‘convert to nonlinear cases’ button and selecting which combos you wish to convert to NL. In most instances, you will want to 

convert all load combos to NL so select/highlight them all with your mouse as shown below and press OK. You will then see a 
message similar to the one below indicating how many combos were converted. You can then go to Define>Load cases to review 

the NL load cases which SAP2000 has automatically generated like the example below right:
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SAP2000’s frame element formulation automatically accounts for both big P-delta sway as well as little p-
delta local member deformation as required by AISC benchmark problems. In many cases no additional 
intermediate joints are required for good results. But in some cases, one additional intermediate joint may be 
required to accurately capture little p-delta reactions. Unlike most other structural software products which do 
not incorporate little p-delta analysis in the element formulation, with SAP2000, you never need to add more 
than one intermediate joint to accurately capture p-delta effects, no matter how complicate the loading. 
Automatically generate 1 intermediate joint for internal analysis only by selecting all    , then 
Assign>Frame>Automatic frame mesh using the parameters shown below with minimum number of 
segments 2 and press OK. Press F4 to remove the automatic mesh assignments from the graphics

Press F4 to remove these assignments from the graphics
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Click ‘Run analysis’ button, then press ‘Run Now’. After the analysis is completed, next click the ‘Start 
steel design’ button       to perform the AISC steel design check. With SAP2000, analysis is run 

separate from design. 

Run 

analysis
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You can right click individual frames to review design results, but because we used autoselect lists, 
you can see below that a different section was selected for design than was used for the analysis. 
SAP2000 uses the median section in each autoselect list as a starting point to determine loads, and 
we need to iterate back and forth between analysis and design, typically 4 – 6 times if lateral loads are 
involved, in order to match the analysis sections with the design sections. You can check analysis vs
design sections using Design>Steel frame design>Verify Analysis vs Design section shown below

When you see this message, typically just click 

No, then analyze and design a few more times 

until analysis and design sections all match
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After analysis and design sections all match, you will see color coded graphical results based on percentage of design code 

allowable. Right click any frame to check results. SAP2000 runs all design combos along every 24” of every frame and 

defaults to display the worst case load combo and worst case location along the frame. Click Details for more info. You can 

see that SAP2000 automatically applied reduction factors to EA and EI per the AISC code for the Direct Analysis Method.

Analysis and design 

section match
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In the design code check, load combo UDSTL10 was the worst case load combo for the frame we just 
checked, so we can spot check deflections by clicking the ‘show deformed shape’ button and select 
UDSTL10 combo. Change units to Kip-in and right click individual joints to check deflections or click 
‘Start animation’ in the bottom right to watch the structure animate under that applied load 
combination. Press F4 to exit deflected shape

Show deformed 

shape button

Units can be 

changed here
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Next, let’s do a spot check on load transfer from the grating to the beams. Click the ‘Show 
forces/stresses’ for frames button       and choose GRATINGLIVE case Moment 3-3 (major). Moments 
show one-way load distribution to girders. Right click beams and bracing for detailed spot-checks to 
see that the grating did not distribute load to the bracing underneath, just like we wanted. Press F4 to 
exit moment diagrams
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To minimize the size of the output reports, we can select just the joints and frames of interest to be 
included. Switch to xy plan view and use up/down arrow keys to go to the top level and select edge 
joints as shown by windowing around them in order to minimize output for max deflection checks. 
Next, use arrow keys to go to the base and window select the restraints. 

Top level edges selected in plan view

Base level selected restraints
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Use Display menu>Show tables to generate output tables. The output in this example will be limited to 
the selected joints, and further limited by selected load cases and reports chosen. Typically avoid 
choosing modal for analysis results except for reporting modal dynamic analysis results
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This is the default report format. As an example, let’s clean it up by clicking Format-Filter-

Sort and formatting it first by eliminating unwanted data which may clutter the report.

Switch 

between 

reports using 

this pull-down
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Click within the Item column to toggle certain items to be ‘Not printed’ (ie. not displayed) in red and press 
OK. Next, go back to Format-Filter-Sort and use Sort by U2 direction (U1, U2, U3 = joint axes X, Y, and Z 
unless local axis was rotated) with Descending check boxed to review max deflection positive Y direction. 
Uncheck Descending to review max deflection in negative direction Y assuming there are negative 
direction deflections
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Sorted max deflection in the Y (U2) direction in this example. Uncheck the ‘Descending’ box in the sort 
dialogue in order to check deflections in – direction.

Max deflection +Y 

direction using 

Sort
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Use File menu to automatically export to Excel as shown below without any manual copy & pasting or 
editing of text files. Every single aspect of the model input and analysis and design results can be 
automatically exported to Excel or Access or imported from Excel or Access. SAP2000 also comes 
with a well documented application programming interface (API) which facilitates integrating SAP2000 
with 3rd party applications as well as plug-in options. API documentation installs in the SAP2000 
directory in a file named SAP2000_API_Documentation.chm
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Use the pull-down to switch from joint displacements to joint reactions and Format-Filter-Sort, then 
Sort for F3 Descending as shown. F1, F2, F3 correspond to global X, Y, and Z unless local axis of 
joints have been rotated.
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Joint reactions now sorted by max vertical reaction. Alternatively use File menu>Create report to 
generate output reports using SAP2000’s default settings for output report generation. You can 
generate custom output reports and save formats using the Advanced report writer.

Max vertical 

reaction for 

selected load 

combos
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Please feel free to contact me with any modeling questions regarding SAP2000, or our SAFE program 
for design of basemat foundations on soil or piles. Also, feedback on this tutorial would be appreciated, 
as we can customize similar tutorials to meet your needs. We are very interested in working with you to 
increase usage of SAP2000 and SAFE wherever you believe it may improve your work process. As you 
can see from this tutorial, SAP2000 can be effectively used for day-to-day modeling and design 
applications as well as for advanced nonlinear and dynamic analysis.

We encourage you to check out our design and user manuals which install in the Manuals subdirectory 
of the SAP2000 installation folder

Watch & Learn video tutorials here: http://www.csiberkeley.com/support_watch&learn.html


