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After clicking File>New or the New Model icon, an initial setup screen appears with the “Default Settings” tab as shown below left. Here the user can  select 
starting units which can be changed later, an option to add an initial point (aka joint) at a specified location, and an option to override ambient temperature and 
pressure if different from the default. Accept default values on this tab and move to “Default Properties” tab shown below right.

The Default properties tab enables users to specify piping design code, spring hanger library (which can be changed later) and specify grid spacing. In this example 
select ASME B31.3-2018 design code (B31.3-2020 is the default), preload the B31.3 material properties library, and accept default grids and default spring hanger 
library by clicking the “Grid Only” button and then click OK.



Grids can be useful when working with Draw commands which snap to grid intersections. Grids also automatically generate planar views as we will see 
later. In this example, add X direction grid lines as shown using the “Add” button. With Grid ID 5 in the X direction, type 77 in the Ordinate field, which 
shows that gridlines do not have to be equidistant.

If grid lines later need to be 
added, deleted or modified, users 
can right-click in the white area 
of a screen to access options 
shown below.



Coordinate system and units are displayed below right and can be changed at any time. If  the mouse cursor snaps to a point/joint or grid intersection, the 
global coordinates of that snap point will display in the bottom right area of the screen.

Note CSiPlant global axes have Z as vertical.



In order to add piping, we must first define a pipe section and then define a pipe property set. Go to Define menu>Pipe Sections, click ‘Import From Library’ 
button, then click the radio button for ‘Name of XML Property File’ as shown below and select (ASME) B36.10 library.

If it was a nonstandard pipe section or a pressure vessel modeled with a large diameter pipe, you would instead click ‘Add New’ and specify diameter, wall 
thickness and material for a custom pipe section. 



Select NPS 16 Sch. 30STD pipe section from the B36.10 library, then select A106-B material as shown.



On the Define Pipe properties dialogue there is a button for Design Properties. This dialogue is used if you want to change the default mill tolerance 
(12.5%) or specify corrosion or erosion allowance for pressure design. In this example we will use the default values.

The Section Properties button displays cross sectional properties of the pipe section in current units. 



Next go to Define menu>Pipe Property Sets, click ‘Add New Property’ button, change Pipe Section to the NPS 16 Sch. 30STD section that we just imported, give 
it a descriptive Name, 16”STD CS, change units as shown below, and then specify Pipe contents as shown. Users can specify fluid contents weight as Specific 
Gravity or by Weight density.  Next, specify custom insulation as shown using 14lbs/ft3 density. Note the thickness field in which the numeric value is appended 
with mm in order enter using millimeter units. CSiPlant will automatically convert to current units. Input can be appended by mm, m, ‘, “, psi, lb, or N



Let’s quickly explore CSiPlant’s temperature-dependent material library for reference purposes only. Go to Define menu>Materials. For B31.3, CSiPlant
also offers Minimum Temperature curves for carbon steel. You can review temperature-dependent material properties and design stresses, as well as 
yield stress and Ultimate stress for each library material. 



Click the Draw Joint icon       , enter -13 ft. in the Offset X field and left-mouse click the origin, which is the intersection of gridlines A and 1. Draw 
commands snap to joints/points, grid intersections, and global axes in the + and – directions. Other than importing from a 3rd party program, there are two 
techniques to create piping models in CSiPlant: Draw commands, which we’ll cover first, and Insert commands, which can be conveniently accessed by 
typing the letter I on your keyboard.

Click the Draw Pipe icon      , change Pipe property set to 16”STD CS and left click on the orphan joint, then click the origin and then click to the grid 
intersection just above the origin as shown below right. Note how CSiPlant automatically adds elbows. 

Then click here

After drawing the orphan joint, 
click here first using Draw Pipe

Then click here



Next, change Elbow radius type from Long radius to Nominal 3D and click to the next grid intersection in X direction, then go down in –Z to the grid intersection 
below at the intersection of gridlines 2 and A as shown and left click that intersection. At this point change elbow radius back to Long radius by clicking Radius 
type field and type the letter L, so only the two elbows on the second level have 3 diameter radius. As you can see, Draw Auto generation options and pipe 
section can be modified on the fly as you create the piping model.

You can quickly switch to 3D 
radius by typing the letter N in 
this field



Move your mouse in the –Y direction as shown, then type 16 on your keyboard and press enter. Because current units are in feet, CSiPlant draws a 16’ run of pipe 
from the elbow tangent intersection point (TIP). Draw commands will snap to points, grid intersections and global axes in the + and – directions.



Now move your mouse to snap in the X direction, type 4.5m and press Enter on your keyboard. CSiPlant automatically converts meter input into current feet 
units. Right-click to end drawing and press Esc key on the keyboard or Select Object icon       to switch from Draw mode to select mode.



Click XZ icon to select plane. Press Ok to accept default 
gridline A. Users can scroll through planar views using 
up/down arrow keys   

In elevation view, hold down left mouse key and drag left to right as shown in 
order to select. Selected elements and joints are highlighted.



Under Edit menu there is a Move command. However, it’s almost always faster to instead use keyboard commands, so type Ctrl+M to access the Move dialogue. 
Enter 8 ft. in the DZ field to expand the loop and click Apply button.



Click undo, then click Previous selection button        enter -3 in the DZ field and press OK reduce the size of the loop. Press undo again to return to original 
dimension

Original dimensions after undo



Click Previous selection button or window select as shown below, then Assign menu>Pipe>Elbow radius to change selected elbows to Long radius. 
Click clear selection icon        to deselect all.

Assign menu>Pipe also has options to assign a different pipe property set to selected elements among other options



Left click anywhere in the screen of the 2D elevation view and click 3D button        to switch from planar view to 3D. Next, we’re going to define a new pipe 
section and pipe property set in order to draw a branch line.

Define menu>Pipe sections to Import from Library NPS 10 Sch 40STD pipe section and apply Material A106-B material. Press OK to complete.



Next, go to Define>Pipe Property Sets and  ‘Add New Property’ as shown for the 10” pipe section we just imported. Units changed to lb ft. for convenience. 
Pipe fluid contents specific gravity 1. Note that Insulation thickness was input as 2” although current units are feet. CSiPlant automatically converts that entry 
into feet units. Press OK to complete.



Click Draw Pipe icon and change Pipe property set to the 10” line that we just defined. Starting at the first point of the model, drag your mouse along the 
pipe in the X direction as shown below left, type 7 and enter. 

Next, drag your mouse in the –Y direction to snap to that axis, type 18 and press enter as shown below right. Note how the tee was automatically added.



Drag your mouse in the –X direction as shown below, type 8’+3” 
(architectural units are entered in this calculator format) and 
press enter and right-click to detach cursor from the end point. 

Press Esc key or Select Object icon to switch to Select mode. Left-click or window 
around each of the 3 end points to select them as shown below. 

Type the letter I on your keyboard then type the letter A to bring up the Insert 
dialogue shown below. Press Insert button to add anchors, then cancel to exit 
the dialogue. Press clear selection icon         to deselect the 3 points.

Anchors added



Go to Design menu>Define Design requests and go to the ‘Design Preferences’ tab.  Make sure that SIF mode, flexibility factor, and Connection SIF are all 
set to ASME B31.3 Appendix D as shown below. We’ll come back to this dialogue later to explore more options. Click OK to accept.



Use rubber band zoom to zoom into the tee, move your mouse to the 
tee midpoint to snap, then right-click to view the Tee dialogue below 
using the Design tab. Note that SIFs are displayed for the default 
welding tee.

Switch to Assignments tab and change Tee type from Welding Tee to Reinforced 
Fabricated Tee as shown below.



Switch back to the Design tab. Because we haven’t yet entered a 
reinforcement thickness, the SIFs have spiked. 

Enter .375” as the reinforcement thickness and tab. The quotation 
mark will automatically convert inches input to current units.

After the reinforcement thickness is entered, the SIFs automatically adjust 
accordingly. As an alternative to the right-click tee modification, users 
could select one or more tees, then use the Design menu>Assign design 
properties for Object type Tee to change tee properties. 

Press OK to exit this form.



To graphically review support local axes, left click Set Display Option       icon as shown 
below. Red/Green/Blue correspond to local axes 1/2/3. Anchor, Guide and Line stop 
supports share the same local axes as the piping, which is useful when modeling skewed 
piping. Note that local axes can also be displayed for joints, pipes, frames, and links.

Pipe supports can have different properties in each 
local direction in which the support is acting.  With 
anchors, options are shown below. 

Other support types offer additional options for gaps, 
friction, and multi-linear stiffness in each direction.



By default, the guide support acts in both vertical and lateral 
directions for horizontal piping (pipe local 2 and 3 directions), but 
users can specify different gaps, friction, and other parameters 
for each acting direction.

Click on the default Guide property then click the ‘Add Copy of Property’ 
button, change the name to Lat Guide using the General tab and then use 
Directional properties tab to specify the Support type “Free” in both the 
positive and negative local 2 direction. This defines a guide support which 
acts only in lateral directions. 

Users can define libraries of custom pipe supports for reuse.



Vertical stop support acts in the Z direction. Open the Vertical stop 
properties, click Vstop, and then click ‘Add copy of Property’ button 
and rename the copy to +VS using the General tab. Change property 
Above to “Free”  as shown, and change properties below to have .3 
Friction coefficient and 0 gap. Click OK to close Define Supports 
dialogue.

Click ‘Draw vertical stop’ icon      and click at midpoint of the loop (there is an 
automatic snap at midpoints) shown below using default VStop property. Next, 
click at midpoint shown below using the +VS property shown below. 

Vstop
vertical stop

+VS property



Zoom in to the tee area and click Draw Guide Icon. Using the default Guide 
property, slide your mouse along the branch in the –Y direction, type 7 (feet) and 
press Enter to Draw the guide.  This dimension is offset from the tee centerpoint.

Below are the 3 supports we added plus a Lat Guide support which  
we will now undo or delete. Note that you can see graphically how a 
support is acting. Gaps are also shown graphically.



Use Define menu>components>Valves and click ‘Import From Library’ to import a 300 lb 16” valve and 10” valve as shown from the built-in Crane valve 
library and press OK to import. CSiPlant will display the valve weight and length. Alternatively, users can define their own custom valve libraries.



After importing the valves, click the “Material Type” field where it says ‘Custom’ to activate its radio button      . Click the button and select one 
of the materials in the list in order review CSiPlant’s material library of temperature-dependent pressure ratings which are available for valve 
and flange objects using ASME B16.34 and B16.5 standards. For this example, select A105 material.



After selecting valve material A105, switch to the Pressure Rating tab to view pressure rating curve. With this data, engineers can determine whether 
their components may be used within those ratings in order to maintain system integrity and safety. This material pressure rating data is also needed 
for flange leakage checks in CSiPlant.  Detailed information on CSiPlant’s flange leakage check per ASME code case 2901 (now incorporated into UG-
44) can be found under the Help menu>Documents>Design>Codes>Supplemental.



Click XY view, Z1 plane as shown below, then window zoom in to the right side. Click Draw valve icon and change Valve property to the 16” valve that we 
just imported. Move your mouse in the X direction away from the elbow and type 5 and press enter on your keyboard to insert the valve “Start point” 5’ 
from the elbow tangent intersection point (TIP). Note how CSiPlant offsets from elbow TIP, not end points, which is consistent with piping isometrics.



After drawing the valve, click undo to remove it.

Next, redraw the valve using the same 5’ offset from elbow TIP, but this 
time change Object offset reference to “End point” as shown below. Since 
drawings can be dimensioned to valve or flange start point, midpoint, or 
end point, offset reference can make modeling more convenient.

Press Esc key on your keyboard to switch to select mode and left click the 
valve that we just drew. Next, type Ctrl M on the keyboard to bring up the 
Move dialogue. Enter 3 in the DX direction and press OK.

When a Move command is applied to selected points/joints, valves, flanges, 
or pipe supports, it slides their location without changing the overall length 
of the piping system.



Next, we will select areas of the piping to assign temperature and pressure loads. There are several different ways to select: left-clicking, window 
zoom, or by dragging a window right-to-left which selects everything which the box intersects. The Select menu offers several other select options 
which can be useful. For this option, let’s use Select by pipeline and select Object label Pipeline-A, which is the header pipeline.



With the header pipeline selected, left click anywhere in the white area of one of the screens away from the piping model andthen type the letters F and then T 
on your keyboard to assign temperature load to the selected elements. For T1, enter 300 for the header and click Apply button. For T1 load pattern/case the 
branch line is ambient. Next, click the “Select all” button, change the load pattern to T2, enter 300 and press OK to close the temperature load dialogue. 

Next, using the select by pipeline dialogue again, select Pipeline-A, then left click in the white area and type F then R to assign pressure load. The default units 
are different than the psi units that we want to work with so type 300psi (with or without a space between 300 and psi) and click Apply for load pattern P1 and 
CSiPlant will convert to current units. Click Apply to apply this pressure load assign Next, click “Select all” button, change load pattern to P2. Type 300psi if it’s 
not already entered by default and press OK to close the pressure load dialogue. Close the Select by Pipeline dialogue. 

Using keyboard commands to assign loads is usually more efficient than using the menu Assign menu>Pipe loads. Although CSiPlant has no limit to the number 
of temperature or pressure loads which can be analyzed, it gives you 2 temperature and 2 pressure load patterns/cases by default. 

300psi input automatically converts to current units

For external pressure, there are several pressure load methods that 
you’ll want to be aware of which can be useful for applying external 
pressure load on subsea risers and pipelines where pressure varies 
with depth. Press F1 key on your keyboard for additional information.

CSiPlant accounts for changes to Poisson effects due to external 
pressure vs internal pressure.



Let’s review the Define menu>Load patterns to review defaults. Load patterns must be defined in order to assign loads. Load patterns control the magnitude 
and distribution of the load, but they cannot provide analysis results. Load cases determine how load patterns are analyzed – as linear or nonlinear, statically or 
dynamically, with or without P-delta. Load cases produce analysis results. If additional thermal, pressure, or wind load cases are required, they must first be 
defined as load patterns by clicking “Add New Load” button. 

Self Weight multiplier of 1.0 is applied to Dead load pattern by default. You would almost never want to apply a self weight multiplier to more than 1 load 
pattern. Otherwise, you could accidentally double or triple count self weight and mass.



Wind and Seismic load pattern types offer auto-load generation by activating the “Auto 
Pattern” option associated with them. Below, by selecting Wind load type with ‘Auto 
Pattern’, users can automatically generate code-based wind loads on piping (and 
structure) using the form below.

Cancel the wind load pattern dialogue. Occasional load cases will be covered in more 
detail in another tutorial. 

By selecting Earthquake load type, you have the option to apply 
acceleration loads (G)  as shown. Alternatively, you can apply static 
acceleration factors using the Load case dialogue, as well as options to 
define response spectrum and time history cases.

Cancel this seismic dialogue and load pattern dialogue and we’ll move to 
the load case dialogue.



Default load cases below. Let’s review the default Displacement stress load case (aka Expansion case) 
highlighted below. Displacement stress case is the subtraction of gravity weight loads (scale factor -1) from an 
operating case. Since pressure causes piping to deflect and is self-limiting like thermal load, by default 
CSiPlant considers pressure elongation as part of the displacement stress case. This default can  easily be 
modified by subtracting pressure along with GR for displacement stress cases.

Whenever there are more than one displacement cases defined, CSiPlant automatically subtracts moments 
between the displacement stress cases in order to check the displacement stress range between cases. If 
worst case displacement stress is from one of the automatically generated range cases, that range case is 
reported as the “controlling load case” in the design report.

When reviewing the Load case dialogue, note the 
load case options, particularly unique load case types 
Buckling, Ritz modal, and Nonlinear time history 
cases which are not possible with most other piping 
stress programs.

All of the load patterns are available as load cases, but you 
would have to define additional load cases to expose them. 
For example, you could define a load case for Insulation 
only as shown below. Same procedure if you wanted to 
create load cases for individual load patterns T1, P1, etc.



With sustained stress code cases, the “reference temperature” is by default used only to specify Sh allowable stress for that load case, not for additional load. 
Pressure elongation is accounted for as a load in B31.3 sustained stress case, but pressure is treated as an equation, PD/4t, by default for sustained stress 
calculations in B31.1. Calculated stresses from the pressure case are added to stresses from the GR weight case to determine B31.3 sustained stresses. Note how 
“Continue from End state of” has GR, which includes reactions from GR in the sustained stress case.

Pressure design load cases, aka “Hoop stress” check cases, similarly use Reference 
temperature only to specify Sh allowable stress, not as an applied load. Reference 
pressure is always applied as an equation per the applicable piping code in pressure 
design cases. Options on how the pressure equation is applied are available in the 
Design requests dialogue which we’ll cover later in this tutorial.

GR “weight” load case automatically combines weight and mass of 
Dead (piping selfweight), fluid contents, insulation, cladding, and 
internal lining.

Here you can specify P-delta 



Click ‘Set Display options’ icon      and checkbox Joint labels to view them. As can be seen 
below, after intermediates joints are added to an existing pipeline, automatically 
generated joint labels for those intermediate joints remain sequential, but they’re often 
not integers.

A similar occurrence can happen with Pipe labels as well, so let’s relabel Joint and Pipe 
labels before generating design and analysis results..

Use Select menu>Select>Select by Pipeline to select Pipelines 
individually using the “Include Connected Elements in Selection” in 
order to select associated joints and pipe elements which we’ll 
relabel. Select Pipeline-A and click “Select” button.



Go to Edit menu>Change labels/renumber and specify Object 
type “Point” and “Custom Relabeling Schema” as shown below 
and click Apply button.

Point labels are now all integers in a logical order.



Because pipe stresses are reported at multiple 
stations along the length of the piping, not just at 
meshed point locations, we will next relabel the 
pipes in a logical pattern. 

Use ‘Set Display options’ as shown below to display 
pipe labels and select Pipeline-A as we did before.

Go back to Edit menu>Change labels/renumber and 
select Object Type “Pipe” and “Use Custom 
Relabeling Scheme” as show to the right and accept 
defaults by pressing Apply button then close.

Because CSiPlant’s graphical review of output 
results is so powerful and versatile, labeling is 
not as important in CSiPlant as it is with other 
pipe stress programs. 

Nevertheless, CSiPlant’s alphanumeric 
labeling options can be useful to have.



Click the “Show design results” icon      to display color-coded design code stresses. In this 
example below, Sustained stress ratios. Hover your mouse above parts of the model to see 
more details. The color-coded legend  for “Show Varying DCR contour” shows that highest 
DCR (demand capacity ratio) is just over 30%.



Use “Show deformed shape” icon      to display X direction displacements GR->(T2+P2) operating case on  the left by clicking the white area in the left screen then 
clicking Apply button and then click in the window on the right to display Z direction displacements for a different operating case, GR->(T1+P1) on the right. If you 
change units in the bottom right, the color-coded graphics values will automatically adjust. 



Use Display design results icon       by clicking the left screen and specify displacement stresses as the Design category and choose “Show Varying DCR 
contour”. The model is overstressed by 1.2% as shown below left. Hover your mouse over the overstressed area at the branch to see the worst case for 
displacement stresses. Click right screen and then click “Display pipe/frame forces” icon       to display bending moments in the 2-2 local direction for the 
GR->(T2+P2) operating case changing units in the bottom right part of the screen to lb ft.



In this example, we use the “Support reactions” icon      to display Z direction reactions from the GR case on the left, and Z reactions from the GR->(T2+P2) 
operating case on the right. This tool enables users to quickly highlight changes in gravity direction loads due to load redistribution from thermal displacement.



Click the “Unlock” icon/button     in order to make a change to the model. Go to Design menu>Define design requests, click “Copy Design request button” and 
give it the name DR-B31J. Although we won’t cover it in this tutorial, the ‘Included objects’ tab enables users to apply different design parameters, including 
different design codes, to different parts of the model using groups.



Design checks tab enables users to control how each category is 
analyzed. Stiffness temperature dependence means use of operating 
temperature modulus. We won’t make any changes here.

Design preferences tab offers users to specify design parameters for each DR, 
enabling users to run sensitivity studies using multiple DRs. In this example we 
change SIFs and flexibility factors to ASME B31J. Note that at the bottom of the 
dialogue is a help description for each field which is highlighted.

For B31.3-2020, ASME B31J is the default in CSiPlant



In this example, we’ll display displacement stresses side-by-side between one DR using Appendix D SIFs and flexibility factors, and the other DR-B31J 
request using ASME B31J SIFs and flexibility factors. As of B31.3 2020, B31J is now the only method allowed for calculation of SIFs and flexibility factors. 



DR-B31J DCR on the right is under the allowable at 82.3% for max displacement stress, whereas the DR on the left using App. D SIFs and 
flex factors is slightly above the allowable as shown below. 



Display menu>Show tables to review tabular output results. If you want to report results only for selected members, then select them before generating 
this table in order to limit the reported results. In this example, we’re going to generate tables for support reactions and displacement stress results. Click 
the Modify/Show options button to select load cases to review. 



Here we select load cases of interest, GR case and the 2 operating cases for review of pipe support reactions. Result sets for both DR and DR-B31J design 
requests will be reported since we choose the “All Except Base” result set. Base result set would be results without piping SIFs or flexibility factors applied. 
Design stress results automatically generate results for all applicable design load cases for each stress category.



File meu on the Table display offers options to export to Excel. The support reactions report include the support label, X/Y/Z coordinates of the support, support 
reactions, and pipe displacements at the support point. Within the CSiPlant tables, right-click the top of any column in order to interactively sort and filter results.



As an alternative to modeling a pressure vessel or tank connection to piping as a 
rigid anchor, we can model the vessel as a large diameter pipe which we’ll do next.

Another potential application for B31J is for calculation of flexibilities at 
nozzle/vessel junctions. Unlock the model by clicking the unlock icon       and go 
to Define menu>Pipe sections to define a 14 ft. diameter “Vessel” pipe as shown 
below, then use it to define a new pipe property set as shown below right.

Define a new Pipe property set for the 14’ Vessel





Click the “Set line view” icon                     to make it easier to manipulate this 
portion of the model, click “Clear selection” icon        and click to select the 
elbow joint shown below. Change offset to 10’ in the Z direction as shown 
below and click Insert button which auto-converts the elbow to a tee using the 
Tee type specified in the “Auto Options” tab. Say OK to the pop-up asking about 
a new branch.

Clear selection then click to select the point at the bottom 
of the vessel as shown below. Change to Insert Anchor with 
0 length, press Insert button to Insert Anchor, then press 
Cancel to complete the insert commands. 



Right-click vessel tee and specify the B31J Design tab parameters below 
for “Design Settings”. Also input Tp reinforcing pad thickness to utilize 
B31J flexibility factors which adds a spring at the nozzle/vessel junction, 
not the vessel tee centerpoint. This example assumes the nozzle is 
attached to the vessel as a reinforced fabricated connection.

Stress results for the rigid “dummy” pipe segment connected to vessel 
centerline and stresses for the vessel itself can be ignored since they 
are non-pipe elements.

Assign appropriate temperature and pressure loads to the newly added vessel. 
Use of “Get previous selection” icon        is useful when assigning multiple loads 
to the same elements as we have here. Wind load will automatically be applied 
to the vessel if it was specified in a load pattern.

Consideration of vessel displacements and local flexibility at the nozzle provide a 
more realistic piping stress analysis, as would consideration of the support 
structure combined with the piping and equipment.

Click ‘Set extruded view’ icon       to switch from single-line to rendered 
view. Use view menu to toggle off grids from view and ‘Set display view’ 
icon to toggle off flow arrow from view for a cleaner appearance.


