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Copyright 

The computer program SAP2000 and all associated documentation are proprietary and 
copyrighted products. Worldwide rights of ownership rest with Computers and 
Structures, Inc. Unlicensed use of the program or reproduction of the documentation in 
any form, without prior written authorization from Computers and Structures, Inc., is 
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Further information and copies of this documentation may be obtained from: 

CSI Educational Services 
Computers and Structures, Inc. 
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Introduction 

This lecture is generally geared towards the intermediate user level of SAP2000. 
However, if you have never used SAP2000 before, do not be set back. We have designed 
this course in such a way that even the inexperienced SAP2000 user will have no 
problem following along. All of the examples that we present (except for the few real life 
models in the beginning) will be drawn from scratch to exhibit the most general and 
common modeling techniques mentioned above. 

We have chosen seven examples that we will describe in the presentation. In these 
seminar notes, you will find descriptions, computer model definitions, and results for 
each example. As we present each example, please feel free to follow along. 
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EXAMPLE I General Modeling Techniques –
2-D Shear Wall Analysis 

Description 

This is a two-story frame analysis, subjected to lateral static loading. There are 4 frames 
in the X-Z plane that consist of 1 inch concrete shell elements. Each frame is meshed 
differently as shown in Figure 1-1.  Only the 2nd frame has edge constraints assigned to it. 

Significant Options of SAP2000 Exemplified 

� Shell Internal and External Meshing

� Edge Line Constraints Application

� Interactive Database Editing using Microsoft Excel

Computer Model Definition 

The 2D frames are two stories high with a story height of 24 ft.  Each bay is spaced 24 ft. 
apart. Kip-inch-second units are used.  The modulus of elasticity used for concrete is 
3600 ksi.   

Other parameters associated with the structure are as follows: 

Coefficient of Thermal Expansion  = 6.500E-06 
Poisson's ratio  = 0.3  
Concrete Compression Strength, f’c   = 4 ksi 
Bending Reinforcement Yield Stress, fy = 60 ksi 

    Slab Properties: 

         Slab Thickness (Bending) = 1 in 
Slab Thickness (Membrane) = 1in 

  Building Loads: 

Lateral Load on Roof level   = 1 kip  
(Load applied in x, y, and z directions) 
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Interactive Database Editing 

Use the Interactive Database Editing form to make any additions, deletions, or 
modifications to the tables selected using the Choose Tables for Interactive Editing form. 
The changes can then be applied to the model and shown in the display area of the 
SAP2000 window. The Interactive Database Editing form has a display area and various 
menu options and buttons that can be used to add records to or delete records from the 
table shown in the display area, copy records, move records, and find or find and replace 
user-specified data. 

� {Table Name} drop-down list. Use the drop-down list near the top of the form to
select the table to be edited. If the alternative method of displaying the form is
used (see above), only one table name will be listed in this drop-down list.

� Spreadsheet area. Modify records in the table by typing directly in the cells,
including using numerical formulas (e.g., 2+3/4). Right-click within any field
(column) and a menu of pertinent operations will appear. The menu includes the
Field Description option, which when clicked displays a form that shows a
description for the item. If the field expects numeric input, the menu includes the
Calculator option, which can be used to speed data entry when formulae are
involved. If the field expects text input, use the View menu > Drop-Down List
command to display a drop-down list of all acceptable values for the selected cell.

Important: Objects and other defined entities are identified by their names in the 
tables. If you change any names, those items will be considered as new when the 
tables are brought back into the model. Do not use interactive table editing to 
rename objects or other defined entities! Instead, use the Edit menu > Change 
Labels command. 
The units used for a given field can be changed by clicking on the cell just below 
the column heading. Select the new units from the drop-down list that appears. 
Changing the units for one field will change the units for other related fields. The 
units chosen while interactively editing tables are temporary. All values will be 
converted back to the current model units when the editing is applied to the 
model. 

We are interested in changing the joint lateral load for frames 2, 3 and 4 from 1 kip to 
1.25 kips.  Go to Edit> Interactive Database Editing>expand and select the joint load 
assignments option and click OK.  A table will appear with all of the joint loads assigned 
to the structure. Click the ‘To Excel button’.  Change all loads to 1.25 kips wherever you 
see a 1 kip load. The excel spreadsheet should look like Figure 1-1: 
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Figure 1-1 Excel Spreadsheet 

Next, save the Excel file and click ‘From Excel’ in the Interactive Database dialogue box.  
All of the changed values will be imported into SAP2000.  Click the ‘Apply to Model’ 
button and then press Done.  As shown in Figure 1-2, the loads have been successfully 
added to the model. 

            Frame 1 Frame 2  Frame 3 Frame 4 

Figure 1-2 2-D view of meshed shell elements  

As you can see in Figure 1-2, Frame 1 is uniformly meshed in a 5x5 pattern.  Frame 2 is 
meshed 5x5 on top and 4x4 on the bottom. The auto edge constraint option has been 



“Optimized Modeling and Design of Structures using SAP2000” 

- 8 -

enabled for Frame 2 only.  Frame 3 has a triangular shaped shell object drawn in the 
middle for joint connectivity.  Frame 4 is identical to Frame 2 except for the fact that 
there is no edge constraint assigned to Frame 4.   Equivalent joint loads have been 
assigned to all 4 structures depending on the number of mesh points along the tops of the 
frames. 

Auto Edge Constraint 

You can assign a specific mesh to area elements under Assign>Area>Generate Edge 
Constraints. In typical finite element analysis, shell elements are connected to other 
elements at corner points only. When an element does not frame into the corner point of a 
shell element, but instead frames into the edge of the shell element, no connection exists 
between the element and the shell element. SAP2000 is able to perform the analysis in 
this fashion. However, SAP2000 also has the capability of using an auto edge constraint. 
The SAP2000 auto edge constraint feature allows you to specify that elements framing 
into the edge of a shell element be connected to the shell element. SAP2000 internally  
takes care of connection between the elements by constraining points lying along an edge 
of the shell element to move with that edge of the element. Additional information 
regarding the auto edge constraint functionality in SAP2000 can be found in “Mesh 
Transitioning and Compatibility – The Automated Line Constraint in ETABS and 
SAP2000”. This paper can be found on page 59 of these notes. 

Results  

 Shown in Figure 1-3 below are the displacements of the top right corner joint for each 
frame. You can see that Frame 4 has uneven meshing between levels and no auto edge 
constraints.  This is why the deflection for Frame 4 is 33% larger that any of the other 
frames.  Frame 4 also has some separation between floors due to the lack of edge 
constraints. 
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    Frame 1    Frame 2    Frame 3    Frame 4 
  ∆= .0626 in               ∆= .0652in                 ∆= .0649 in   ∆= .0817 in  

Figure 1-3 Deflected Shape in X-Direction 

Figure 1-4 shows the stress diagram (S22) for all four shell structures. To view stress 
diagrams, go to Display>Show Forces/Stresses> Shells and select the component you 
wish to see. You can see that the stress contours shown in Frame 4 are not continuous 
because the edge constraint option has not been activated.  A direct load path has not 
been established in Frame 4. 

       Frame 1          Frame 2           Frame 3           Frame 4 

Figure 1-4 Stress Contours (S22 component) 
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EXAMPLE II Modeling Techniques using Templates –
Transmission Tower 

Description 

This is a four-story transmission tower structure with brace elements located at each 
level. Each floor has a 20 ft. story height.  Each bay is 16 ft. long in the X-direction and 
16 ft. long in the Y-direction. The structure is laterally supported by a numerous brace 
elements located throughout the tower.  Please refer to Figure 2-1 to see the system 
geometry setup. 

Significant Options of SAP2000 Exemplified 

� Object Based Modeling Using Templates

� Open Structure Wind Load Analysis

� Transmission Towers

� Dynamic Analysis- Response Spectrum Analysis

� Eigenvector and Ritz Analysis

Computer Model Definition 

To create this model, go to the File Menu> New Model and select the 3D trusses option. 
Click on the 3D Truss Type pull down menu in the top left hand corner. Select the 
Transmission Tower 3 option. Leave all of the default settings and select the parametric 
definition button to view the model parameters.   
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Figure 2-1 Transmission Tower 3 Parameters 

Wind load Assignment 

In the model, we will assign wind load using the ASCE 7-02 code. Under the Define 
Menu, click on the Load Cases option.  Type in a load case name, select a WIND load 
type and click the Add New Load button.  Highlight the WIND load case and click on the 
Modify Lateral Load button.   

If ASCE 7-02 code was selected in the Auto lateral load drop-down box on the Define 
Loads form (the form that precedes use of this form) and the Exposure from Area Objects 
option is selected, two check boxes will be added in this area of the form:  1) Include 
Area Objects check box and 2) Include Frame Objects (Open Structure) check box. Since 
the transmission tower contains no area elements, choose the exposure from frame 
objects option.  

Please refer to Figure 2-2 as a guide.  The Wind Exposure Parameters will be disabled in 
this form.  The Exposure Height is 80 ft. (maximum Z).  For the Wind Coefficients, leave 
all of the default values for this example (Wind speed: 70 mph, exposure type: B). Click 
the OK button. 
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Figure 2-2 ASCE 7-02 Wind Loading Form 

To view the ASCE 7-02 wind loads assigned to the structure, go to the Display menu and 
select Show Load Assigns>Frame/Cable. From the pull down menu, select the Wind load 
case and click on the Open Structure Wind Loads option in the bottom right hand corner 
of the screen. The loads will be displayed on all of the frame elements including the 
columns and braces. Please see Figure 2-3: 

Figure 2-3 Open Structure Wind Load Display (Elevation) 
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Response Spectrum Analysis 

A response spectrum function is simply a list of period versus spectral acceleration 
values. In ETABS the acceleration values in the function are assumed to be normalized; 
that is, the functions themselves are not assumed to have units. Instead the units are 
associated with a scale factor that multiplies the function and is specified when you 
define the response spectrum case.  

Define response spectrum functions as follows: 

Click the Define menu > Functions> Response Spectrum Functions command to access 
the Define Response Spectrum Functions form. The Response Spectra area of this form 
lists the names of all the currently defined response spectrum functions.  Select the 
UBC97 spectrum and click OK. 

After a response spectrum function has been defined, define a response spectrum case as 
follows: 

Click the Define menu- > Analysis Cases >Add New Case> and from the pull down 
menu, select Response Spectrum.  Click on the Modal Damping button on the bottom of 
the dialogue box. Enter the structural damping as .05.  It is important that you understand 
the structural and function damping item. This item specifies modal damping that is 
present for all modes in the response spectrum analysis. Also, SAP2000 assumes that the 
response spectrum functions specified for the response spectrum case are all specified for 
this particular damping ratio. 

Select the Complete Quadratic Combination (CQC) option. This is the CQC method 
described by Wilson, Kiureghian and Bayo (1981). This modal combination technique 
takes into account the statistical coupling between closely spaced modes caused by modal 
damping. Increasing the modal damping increases the coupling between closely spaced 
modes. If the modal damping is 0 for all modes, then the CQC method degenerates to the 
SRSS method. 

Select the SRSS directional combination option.  For each displacement, force or stress 
quantity in the structure, modal combination produces a single, positive result for each 
direction of acceleration. These directional values for a given response quantity are 
combined to produce a single positive result. SRSS combines the directional results by 
taking the square root of the sum of their squares. All other input items remain 
unchanged. The results obtained using this method do not vary regardless of the 
excitation angle that you specify. This is the recommended method for directional 
combination and is the default. 

Under the Loads Applied area, specify any defined response spectrum function for each 
of the three local coordinate system directions of the response spectrum case. In this case, 
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the default spectrum name is UNIFRS unless changed in the previous response spectra 
definition dialogue box. Click Add and the OK to conclude the response spectrum input 
for this model. 

Eigenvector and Ritz Analysis 

Research has indicated that the natural free-vibration mode shapes are not the best basis 
for a mode-superposition analysis of structures subjected to dynamic loads. It has been 
demonstrated (Wilson, Yuan, and Dickens 1982) that dynamic analyses based on load-
dependent Ritz vectors yield more accurate results than the use of the same number of 
natural mode shapes. 

Ritz vectors yield excellent results because they are generated by taking into account the 
spatial distribution of the dynamic loading, whereas the direct use of the natural mode 
shapes neglects this very important information. 

In addition, the Ritz-vector algorithm automatically includes the advantages of the proven 
numerical techniques of static condensation, Guyan reduction, and static correction 
because of higher-mode truncation. 

The Analysis Case Data - Modal form is used to view and change the definition of a 
modal analysis case. A modal analysis is always linear. Choose between Eigenvector or 
Ritz vector modal analysis types. Eigenvector analysis determines the undamped free-
vibration mode shapes and frequencies of the system. These natural modes provide an 
excellent insight into the behavior of the structure. Ritz vector analysis seeks to find 
modes that are excited by a particular loading. Ritz vectors can provide a better basis than 
do eigenvectors when used for response-spectrum or time-history analyses that are based 
on modal superposition. 

Tip: The program automatically creates an eigenvector modal analysis case when a new 
model is started. Calculating and reviewing the first few natural modes (eigenvectors) of 
a structure is an excellent way to check the model for errors and to gain insight into its 
behavior. 

Note: An infinite number of modal analysis cases can be created. However, for most 
purposes, one modal analysis case is enough. 
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EXAMPLE III Truss Modeling –
Curved Steel Truss Example  

Description 

This is a 166 ft steel truss with curved upper and lower chord elements.  The lower chord 
of the truss has a top elevation of 12 ft and the upper chord has a top elevation of 24 ft.  

. 

Significant Options of SAP2000 Exemplified 

� Curved Frame Elements

� Edit Grid Options

� Truss Optimization Modeling

� Steel Frame Design

� Steel Frame Drift Optimization

Computer Model Definition 

To create this model, go to the File menu>New Model and select the Grid Only option. 
Under the Cartesian Tab, fill in the number of Grid lines in the X-direction (2), Y-
direction (1) and Z-direction (2).  The grid spacing is 2000 inches in the X direction, 288 
inches in the Y direction, and 72 inches in the Z direction.  Click OK and the grid will be 
shown. 

Curved Frame Element Generation 

Go the Draw menu>Draw frame element and select the curved frame option in the line 
object type menu. Click on the grid intersection that defines the beginning point for the 
curved frame. Select the X-Z button on the top of the screen and click the point that is the 
origin of the X-Z plane. Then, click on the grid intersection to define the end of the 
curved frame at point X=2000 and Z= 0. When the mouse button is released, the 
Parameters for Curved Frame and Cables for Line Object form are displayed. Use the 
form to review/change the section property, number of linear segments, computed 
coordinates of the linear segments and so on. Fill in the parameters as shown in Figure    
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3-1 and click OK.  Create a second curved but with the end points starting at X=0, z=72
and ending at X=2000 and Z=72.  The 3rd

Figure 3-1 Curved Frame Parameters Dialogue Box 

Create a second curve but this one with the end points starting at X=0, z=72 and ending 
at X=2000 and Z=72.  The 3rd   point for the second curve has coordinates (1000, 0, 288).  
You can see the 3rd point for the first curve in Figure 3-1. (1000, 0, 144) 

Now, the 2 curves are shown in the X-Z plane. Under the View menu>Set Building 
Options, deselect the invisible button under the Joints box.  You will now be able to see 
that the curved beams have been broken up into 10 segments each. Using the 
Draw>Draw frame element option, draw in a truss configuration as shown in Figure 3-2:  
Next, assign joint restraints to the two end joints.  The left joint is pinned and the right 
joint is a roller restraint.  
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Figure 3-2 Curved Truss  

Auto Select Lists (Truss Optimization) 

Auto select section lists are lists of previously defined steel sections (including cold-
formed steel). When an auto select section list is assigned to a frame member, the 
program can automatically select the most economical, adequate section from the auto 
select section list when designing the member. Auto Select Section Lists are used in Steel 
Frame, Aluminum Frame, and Cold-Formed Steel Frame design. At least two steel frame 
sections must be defined before you are allowed to define an auto select section list. 

Define an Auto Select Section List as follows: 

1. Click the Define menu > Frame Sections command to display the Frame
Properties form.

2. In the "Click to" area of that form, scroll down the drop-down list that initially
reads "Add I/Wide Flange" to locate and highlight "Add Auto Select." This will
bring up the Auto Selection Sections form.

3. Use the Auto Selection Sections form to name your auto select section list and
choose the sections to be added or removed from that list.

a. Auto Section Name: Type a name into the edit box.
b. Choose Sections: Locate the sections you wish to include in your auto

select list in the List of Sections display box. Use standard Windows
methods to select the desired sections (i.e., click on a section and hold
down the left mouse button as you drag the mouse down the list to select
multiple sections; highlight a section and click the left mouse button to
select sections one at a time; hold down the Ctrl key and click the left
mouse button to make random multiple selections). Click the Add button
to add the selected beams to the Auto Selections list on the right side of
the form. If you want to remove a section(s), highlight it in the Auto
Selections list and click the Remove button. Removing a section from the
Auto Selections list does not removed it from the List of Sections.
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Next, select all of the members of the truss, go to the Assign>frame element>frame 
section box and select AUTO1 section list.  Now, a specified list of sections is assigned 
to the truss elements. 

Steel Displacement Targets 

For displacement optimization, SAP2000 predicts which members should be increased in 
size to control the displacements based on the energy per unit volume in the members. 
The members with more energy per unit volume are increased in size a larger percentage 
than those with smaller energies per unit volume. Some members with small energy per 
unit volume may be decreased in size if they are still acceptable for strength 
considerations. 

Auto Select Lists must be assigned to the frame elements for the displacement 
optimization to work. When SAP2000 increases or decreases a section size, it uses the 
available sizes in the auto select list. If the appropriate sections are not included in the 
auto select lists, you may never reach your displacement target no matter how many 
times you iterate by rerunning the analysis and design. 

Specify a displacement optimization specification as follows: 

1. Click the Design menu > Steel Frame Design > Set Lateral Displacement Targets
command to open the Lateral Displacement Targets form where you can specify
displacement targets for various load cases. Our intent is that you pick a point,
typically at the roof level of your building, and specify a maximum displacement
target (in any direction) for one or more load cases.

2. In the Loads area of the Lateral Displacement Targets form, select the Load Case
for which you want to optimize the displacement by selecting it from the drop-
down list.

3. Specify the location for the displacement by specifying a Point.
4. Specify the target displacement.
5. Click the Add button.
6. Repeat Steps 1 through 5 as needed.
7. Rerun your analysis with the new section sizes to review the displacements.

Displacement optimization is an iterative process that typically requires you to
rerun the analysis and design multiple times. There is no guarantee that you will
reach your displacement target using this option.

Now, before the model is ready to be analyzed, we must set the analysis options. Go to 
Analyze> Set Analysis options.  Select the Plane Frame option, which restricts the 
available degrees of freedom for a 2-D frame. Next, go to Analyze>Run Analysis to bring 
up the Analysis cases to run form. The Analyze menu > Set Analysis Cases to Run and 
Analyze menu > Run Analysis commands both open the Set Analysis Cases to Run form. 
Use this form to: 
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� Check the analysis status of the cases
� Delete results for cases that have already been run
� Set which cases are to be run
� Run the analysis, or just save the settings

The table on the form lists all defined analysis cases, showing: 
Case Name: The name defined for an analysis case. 
Type: The type of analysis case. 
Status: Shows the status of the case following its most recent analysis. Values 
are: 

o Not Run: The case has never been run or its results have been
deleted

o Could Not Start: An attempt was made to run the case, but a
prerequisite case was did not finish

o Not Finished: The analysis was unable to reach its requested final
state

o Finished: The analysis completed successfully

Action: A value set by the user indicating what should happen the next time an 
analysis is run: 
Run: Indicates that SAP2000 should run the analysis case. 
Do Not Run: Indicates that SAP2000 should not run the analysis case. 

Running Cases 

Use the Set Analysis Cases to Run form to change the action for individual cases or for 
all cases simultaneously. If a case is set to Run, all prerequisite cases will also be run, 
even if the have been set to Do Not Run. 
Click the Run Now button and the analysis will begin and all cases set to run and their 
prerequisite cases will be run. Click the OK button and the action settings will be saved 
but the analysis will not run. Click the Cancel button and the action settings will be left 
unchanged. 

Run the Analysis to see the deflected shape of the truss.  See Figure 3-3: 
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Figure 3-3 Deflected Shape of Curved Truss (extruded view) 

Steel Frame Design 

The Design menu > Steel Frame Design > Start Design/Check of Structure command 
starts the steel frame design process.  

Run a steel frame design as follows: 

1. Click the Analyze Menu >Run Analysis command to run an analysis of
the model. You must analyze the model before you can design it. Thus, the
Design menu > Steel Frame Design > Start Design/Check of Structure
command is not available if you do not first run an analysis.

2. Click Design menu > Steel Frame Design > Start Design/Check of
Structure command.

Note:  

This command is unavailable if no frame elements with the Steel Frame design 
procedure have been included in the model.  

If you have selected frame elements when you click this command, only the selected 
frame elements are designed. If no frame elements are selected when you click this 
command, all steel frame elements with the Steel Frame design procedure are designed. 

Review some of the results of the steel frame design directly on the SAP2000 model (i.e., 
on screen) using the Design menu > Steel Frame Design > Display Design Info 
command. This command displays Design Input and Output parameters.  

Display design information on screen as follows: 

1. Run an analysis.
2. Perform at least one design using the Design menu > Steel Frame Design > Start

Design/Check of Structure command.
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3. Select the Design menu > Steel Frame Design > Display Design Info command to
access the Display Design Results form.

4. Check the Input or Output check box and select from the drop-down list the type
of information to be displayed on screen.
� Right click on a frame element to display the Steel Stress Check

Information Form, which also can be displayed using the Interactive Steel
Frame Design command. See Figure 3-4:

Figure 3-4 Steel Stress Check Information 
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EXAMPLE IV Bridge Analysis –
Concrete Box Girder Bridge Example 

Description 

This example demonstrates the powerful bridge module in SAP2000. The model is a 
concrete box girder bridge with a 220 ft span and 2 lanes. The bridge has 3 columns with 
different heights supporting the deck at midspan. There are parametric variations along 
the length of the bridge as well as prestressed tendons assigned to the deck. The bridge 
abutments are skewed 15 degrees at the 2 ends of the bridge deck. 

Computer Model Definition 

The overall deck depth has a depth 5 ft and a width of 36 ft.   Kip-feet-second units are 
used.  To see the deck cross-section geometry, please refer to Figure 4-1. 

Other parameters associated with the structure are as follows: 

Clear span of bridge  = 220 ft 
Overall depth of deck   = 5 ft 
Width of deck, b  = 36 ft 
Concrete strength, f’c   = 4000 psi 
Yield strength of steel, fy = 60000 psi 
Concrete unit weight, Wc = 150 pcf 
Modulus of elasticity, Ec = 3600 ksi 
Modulus of elasticity, Es = 29000 ksi 
Poisson's ratio, v = 0.2 

Significant Options of SAP2000 Exemplified 

� Bridge Analysis

� Influence Lines and Surfaces

� Use of Prestress Tendons
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To build the bridge model, a 12-step process is required.  Follow the steps listed below to 
build a bridge model based on user-specified definitions. The user must define the 
following parameters: 
 

1. Layout Lines 
2. Deck Sections 
3. Abutments 
4. Bents 
5. Diaphragms 
6. Hinges 
7. Parametric Variations 
8. Bridge Object definitions 
9. Update of linked model 
10. Lanes 
11. Vehicles/ Vehicle Classes 
12. Analysis Cases 

 
 
The user can quickly define a basic model that applies program defaults using the 
following abbreviated approach: 
 
     a. Define a layout line using Step 1. 
     b. Define a deck section using Step 2. 
     c. Skip to Step 8 to create a bridge object. 
     d. Create a linked model using Step 9. 
 
For the abbreviated approach, SAP2000 will apply default abutment, bent, hinge, and 
diaphragm properties.  If necessary, Steps 3, 4, 5 and 6 of this Wizard can be used to 
change those default definitions.  In addition, prestressed tendons can be added as part of 
the bridge object definition (see Step 8). 
 
Each one of the 12-steps is described in great detail.  
 
 
Step 1:  Layout Lines 
 
The first step in creating a bridge object is to define the layout line.  Layout lines are used 
as reference lines for defining the vertical and horizontal layout of bridge objects and 
lanes. 
 
Layout lines are defined in terms of stations, bearings and grades.  The lines may be 
straight, bent or curved both in the horizontal and the vertical plane. Horizontal curves 
are circular (with spirals if necessary) and vertical curves are parabolic. In this example, 
the End Station is defined as 220 ft.   
 
 



  “Optimized Modeling and Design of Structures using SAP2000”      

- 27 -

Use the Quick Start options to quickly define a layout line. You will see the many 
choices available for both Horizontal and Vertical curves.  Select the Straight curve in 
both cases. 

Step 2:  Deck Section Definition 

Various parametric bridge deck sections are available for use in defining a bridge.  They 
include concrete box girders, concrete beam and steel beam sections. Select the External 
Girders Vertical option. Enter the total width and depth shown in Figure 4-1 below.  
After a deck section has been defined it can be assigned to a span as part of the bridge 
object definition (see Step 8).  

Figure 4-1 Define Bridge Section Data Form 
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Step 3:  Abutment Definition 

Abutment definitions specify the support conditions at the ends of the bridge. 

An abutment definition can be a specified Link/Support property or it can be a user 
defined support condition.  The user support condition allows each of the six degrees of 
freedom at the abutment to be specified as fixed, free or partially restrained with a 
specified spring constant. 

An abutment definition also allows the horizontal location of the abutment supports to be 
specified.  A single abutment support can be located at the reference line location or 
multiple abutment supports can be located either at each girder or equally spaced over the 
bridge width.  When multiple locations are indicated the specified abutment support 
properties are provided at each support location. 

It is also possible to specify that a closure (vertical diaphragm) of some thickness is to be 
provided at the abutment.  This closure is only applicable to area object and solid object 
models.  

For this example, select the U2 direction to have a ‘Free’ release type. The other 
directions should have a ‘Fixed’ release type. Under the Horizontal Location of 
Abutment Supports, select the every girder location option.  

Step 4:  Bent Definition 

Bent definitions specify the geometry and section properties of the bent cap beam and the 
bent column(s).  They also specify the base support condition of the bent columns. 

The specified base support condition for a bent column can be Fixed, Pinned or a user 
defined column support.  A user defined column support can be a specified Link/Support 
property or it can be a user defined support condition.  The user support condition allows 
each of the six degrees of freedom at the column base to be specified as fixed, free or 
partially restrained with a specified spring constant. The user defined column support is 
defined separately from the bent. 

It is also possible to specify that a vertical diaphragm is to be provided at the bent 
location.  The diaphragm is only applicable to area object and solid object models.  It 
does not apply to spine models. 

After a bent is defined it can be assigned to the bridge as part of the bridge object 
definition (see Step 8).             
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 In this example, click on the Bride menu> Bents and select the Add New Bridge Bent 
option.  In the Bent Data box, type in the number of columns: 3.   Next, click on the 
Modify/Show Column Data box in the lower left hand corner.  Fill out the form as shown 
in Figure 4-2 below and click OK. Make sure you are in Kip-ft units. 

Figure 4-2 Bridge Bent Column Data Form 

 Step 5:  Diaphragm Definition 

Diaphragm definitions specify properties of vertical diaphragms that span across the 
bridge. 

A diaphragm property can be solid concrete; steel X, V or K bracing; or a single steel 
beam.  Solid concrete diaphragm properties are only applicable to concrete bridge 
sections.  Steel diaphragm properties are only applicable to steel bridge sections. 

Diaphragms in general are only applicable to area object and solid object models.  They 
do not apply to spine models. 
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After a diaphragm definition has been created it can be assigned to one or more spans in 
the bridge object (see Step 8). 

It is not necessary to define a diaphragm property before defining a bridge object.  If no 
diaphragms are defined when a diaphragm is first added to a bridge object, the program 
automatically creates a default diaphragm property. For this example, we will not assign 
specific diaphragm properties.  

Step 6:  Hinge Definition 

Hinge definitions specify properties of hinges (expansion joints) and restrainers. 

A hinge property can be a specified Link/Support property or it can be a user-defined 
spring.  The user spring allows each of the six degrees of freedom at the hinge to be 
specified as fixed, free or partially restrained with a specified spring constant. 

A restrainer property can be a specified Link/Support property or it can be a user-defined 
restrainer.  The user restrainer is specified by a length, area and modulus of elasticity. 

A hinge definition also allows the horizontal location of the hinge springs and restrainers 
to be specified.  A single hinge spring (and restrainer) can be located at the reference line 
location or multiple hinge springs (and restrainers) can be located at each girder or 
equally spaced over the bridge width.  When multiple locations are indicated the 
specified spring and restrainer properties are provided at each support location. 

It is also possible to specify that a vertical diaphragm is to be provided at the hinge 
location.  The specified diaphragm is provided on each side of the hinge.  This diaphragm 
is only applicable to area object and solid object models.  It does not apply to spine 
models. 

After a hinge definition has been created it can be assigned to one or more spans in the 
bridge object (see Step 8).  It is not necessary to define a hinge property before defining a 
bridge object.  If no hinges are defined when a hinge is first added to a bridge object, the 
program automatically creates a default hinge. That is the case for this example. 

Step 7:  Parametric Variation Definition 

Parametric variations define variations in the deck section along the length of the bridge. 
Any parameter used in the parametric definition of the deck section can be specified to 
vary.  One or more of the parameters can vary at the same time.  Each varying parameter 
can have its own unique variation. 

Example uses of parametric variations include varying the bridge depth and the thickness 
of girders and slabs along the length of the bridge.  The variations may be linear, 
parabolic or circular. 
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After a variation has been defined it can be assigned to spans in the bridge object (see 
Step 8).  When a variation is defined it should be defined with the same length as the 
bridge span to which it is assigned.  

For this example, we will define 2 variations (one for each side of the bridge.) Under the 
Bridge Menu>Parametric Definitions>Add New Variation, select the quick start button 
and select the Parabolic Linear variation and click OK.  Fill out the form as shown in 
Figure 4-3 below: 

Figure 4-3 Parametric Variation Definition Form 
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Next, follow the same steps from above to create a 2nd variation.  Click on the Add Copy 
of Variation button in the Define Variations dialogue box.  Go to Quick Start and click on 
the Linear Parabolic option (the exact opposite of the previous variation). Name this 
variation PVAR2 and fill in the Distance and Dimension Change boxes as shown in 
Figure 4-4: 

Figure 4-4 Parametric Variation Definition Form  

Step 8:  Bridge Object Definition 

The bridge object is the heart of the bridge modeler.  The following is included in the 
bridge object definition: 

a. The bridge spans are defined.
b. Deck section properties are assigned to each span.
c. Parametric deck section variations may be assigned to each span.
d. Abutment properties and skews are assigned.
e. Bent properties and skews are assigned.
f. Hinge locations, properties and skews are assigned.
g. Super elevations are assigned.
h. Prestressed tendons are defined.

Any time a bridge object definition is modified the linked model must be updated (see 
step 9) for the changes to appear in the SAP2000 model. 

The prestress tendon quick start options allow quick and easy layout of prestressed 
tendons.  The prestress tendon parabolic calculator makes quick work of the layout of 
parabolic prestress tendons. 

Click on the modify/show bridge object in the Define Bridge Object menu.  In the Define 
Bridge Object Reference Line box, fill in the parameter as shown in Figure 4-5: 
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Figure 4-5 Bridge Object Reference Line Form 

Next, click the on Modify/Show spans button. In this dialogue box, for Span 1, double 
click on the span varies box.  A Bridge section variation box will open.  Double-click on 
the variation for Total Depth box and select PVAR1 and click OK. Do the same for the 
next span except select PVAR2 for the variation.  

Click on the Modify/Show Bridge Prestress button and select Add new Tendon.  Fill in a 
tendon area of 10 in2 and load force of 1500 kips. Select a Prestress load case.  (To create 
a Prestress load case, go to Define>Static Load Cases dialogue box.) Click on the Quick 
Start button for vertical layout and select parabolic tendon 1 and click Ok twice.  Click on 
the Copy to all girders options, which will create 4 total tendons. 

Step 9:  Update Linked Model  

The update linked model command creates the SAP2000 object-based model from the 
bridge object definition. If an object-based model of the bridge object already exists, it 
will be deleted when the new object-based model is created using all of the latest changes 
to the bridge object definition. 

Spine models, area object models and solid object models of the bridge can be created 
when the linked model is updated.  The type of object-based model created from the 
bridge object definition can be switched at any time.  

Under the Bridge menu, select the Update Linked Bridge Model option.  Then click on 
the Update as Area Object option.  Your model should look like Figures 4-6 and 4-7: 
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Figure 4-6 Bridge Elevation 

In Figure 4-6, you can see the parametric variation along the length of the deck.  You can 
also see the parametric tendons located inside the bridge deck.  

Figure 4-7 3D View of Bridge 
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Step 10: Lane Definition 

Lanes must be defined if you want to analyze your bridge for vehicle live loads. 

Lanes can be defined with reference to either layout lines or existing frame objects.  A 
single lane is referenced to one or more layout lines or one or more frame objects but not 
a combination of layout lines and frame objects.  Lanes can be defined with width if 
desired.  Lanes are used in the definition of Moving Load type analysis cases and in 
Moving Load type load cases which can be used in static and dynamic multi-step analysis 
cases.   

For this example, click on the Add New Lane Defined from Layout Line button.  Add a 
lane at two stations. (0 ft and 220 ft) Each of these stations has the same centerline offset 
(7ft) and lane width (14ft). Click OK. Next, add a copy of a lane and change offset by 
specified amount (-14ft).  

Step 11: Vehicle Definition 

Vehicles must be defined if you want to analyze your bridge for vehicle live loads.  In 
SAP2000 vehicles loads are applied to the structure through lanes. 

If you plan to use a moving load type analysis case then you must also define one or more 
vehicle classes.  A vehicle class is simply a group of one or more vehicles for which a 
moving load analysis is performed (one vehicle at a time). 

Numerous standard vehicle definitions are built into the program.  In addition the General 
Vehicle feature can be used to create your own vehicle definition.  Each vehicle 
definition consists of one or more concentrated and/or uniform loads. 

Under the Bridge menu, select vehicles and click the Add Vehicle button.  Add an HSN-
44-1 type vehicle and click OK. From the Bridge menu again, select the Vehicle Classes
option.  Click Add New Class and select the HSN-44-1 vehicle and click Add.

Step 12: Analysis Cases 

Although any analysis case type can be used when analyzing your bridge, there are 
several analysis options that are specialized for analysis of vehicle live loads. 

Moving load analysis cases compute influence lines for various quantities and solve all 
permutations of lane loading to obtain the maximum and minimum response quantities. 

Multi-step static and multi-step dynamic (direct integration time history) analysis cases 
can be used to analyze one or more vehicles moving across the bridge at any speed.  
These multi-step analysis cases are defined using special moving load type load cases 
that define the direction, starting time and speed of vehicles moving along lanes. 
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Under the Define menu>Analysis Cases> click add new case. Under the analysis case 
type, select Moving Load and add the VECL1 vehicle class and click OK. 

Creep and Shrinkage 

Under the Define>Material Properties> select Concrete and click Modify/Show 
Properties.  Select the Time Dependent Properties and click on the Creep and 
Shrinkage option. 

� Time Dependent Properties for Concrete.  Use the Time Dependent Properties for
Concrete form to specify the Strength and Modulus of Elasticity/CEB-FIP
coefficient, as well as the Creep and Shrinkage factors for the material definition.

After the time dependent properties have been specified as part of the material property 
definition, the time dependent properties are applied to the model by assigning the 
material property definition (that includes the time dependent properties) to a selected 
area(s), frame(s), cable(s), tendon(s) or solid(s).  

Results 

The influence lines can be displayed for the various displacements, reactions, forces, 
moments, shears, torsion or axial loads on joints, frames, shells, planes, solids, solids, and 
links resulting from a unit load on a defined bridge lane in the structure. 

After lanes have been defined and a moving analysis case has been defined and run, 
select a column and click the Display menu > Show Influence Lines/Surfaces command 
to display the Show Influence Lines/Surfaces form.  See Figure 4-8: 
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Figure 4-8 Influence lines on Deck 

You can view Bridge forces and stresses for any load case.  Go to Display>Show Bridge 
Forces/Stresses to display the objects response display form.  Click the stresses option, 
select the prestress load case and select the longitudinal stress –Top and Bottom Right –
S11.  See Figure 4-9 to see what is shown: 
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Figure 4-9 Bridge Object Response Display 
 
 
Section Cut Forces 
 
There are two options available to define Section Cuts: 
 

1. The first option is to define the location of the cut.  Use the Define menu > 
Section Cuts command to obtain resultant forces acting at section cuts 
through a model. Define section cuts before or after an analysis is run; 
however, it is safest to wait until after the analysis has been run. Typically 
do not define section cuts, and more importantly, the groups used in the 
section cut definition, until all manual meshing of the model (if any) has 
been completed. If the groups are defined before manual meshing, some of 
the point objects that should be in the group may not yet be created. 

 
2.  The second option is to manually draw the section cut on any portion of 

the model. This can be by utilizing the Draw>Draw Section Cut option.   
You must make sure that the model has been analyzed and you are 
viewing a member force/stress diagram.  This can be found under 
Display> Show Member Force/Stress Diagram> select either frame or 
shell forces.  This second option is used in this example to obtain section 
cuts forces.  
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To obtain shell stress forces on the bridge deck, go to Draw > Draw Section Cut.  Draw a 
line parallel to a Grid line. The flashing line represents the section cut. Section Cut forces 
will now be visible on the screen.  Please refer to Figure 4-10: 

Figure 4-10 Section Cuts force output 
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EXAMPLE V Advanced Modeling Techniques –
Eight Story Parking Garage Structure  

Description 

This is an eight-story parking garage structure with curved ramps located at each level. 
Each floor has a 12 ft story height.  Each bay is 24 ft. long in the X-direction and 36 ft. 
long in the Y-direction. The structure is laterally supported by a curved shear wall system 
located at the edge of the ramp system.    

Significant Options of SAP2000 Exemplified 

� Replication Features

� Extrude Lines to Areas Feature

� Straight and Spiral Parking Garage Ramp Generation

� Draw Developed Elevations

� Creation of OpenGL Views

� Concrete Floor Diaphragm Shears & Section Cuts

� Element Property Modification Factors

Computer Model Definition 

Grid and Line Generation  

The structure is an 11-column line, 5-bay system.  Kip-inch-second units are used.  
Spacing in the X and Y direction is 24 and 36 ft. respectively. It is an 8-story structure 
with 12 ft story heights. 

To create this model, go to X-Z plane at y=864.  Draw a line from Grid line A to Grid 
line C.  Select this line, go to Edit> Replicate> dz = -288in and under increment data, 
enter 3. Draw a line from Grid line I to Grid line K and replicate this line on all odd story 
levels.  Next, draw a line starting at level 8 diagonally down to level 7 connecting each 
line at every level. (In this example, it does not matter which beam size you select). 
Currently, the model should look like Figure 5-1: 
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Figure 5-1 Elevation of Ramp Structure 
 
Ramp Generation 
 
Next, select all flat beams on every level and every other inclined beam element. Go to 
Edit > Extrude Lines to Areas > Linear.  In the Increment Data box, enter 36 ft. for dy 
and number of replications = 2.  Now, select all of the flat beams again and the inclined 
beams that were not selected the first time. Perform the same extrusion application except 
use –36ft for dy. Your model should now look like 5-2: 

 

 
 

Figure 5-2 3-D View of Ramp Structure 
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Circular Edge Ramp Generation 

Now, we are ready to create our circular ramp.  Go to Elevation A, and draw a line from a 
point in between Grid line 3 and 4 to Grid line 5. (Make sure snap to lines and edges is 
activated under Draw> Snap to > Line and Edges). Replicate this line on all even floors. 
Select all lines in Elevation A, go to Edit> Extrude lines to Areas> Radial tab. The ramp 
is a semi-circle so enter 10-degree angles extruded 18 times creating a 180-degree curved 
surface.  The total drop of the ramp is 2 stories or 288 in.  

Figure 5-3 Extrude Lines to Areas Box 

After completing this step, your model should look like Figure 5-4: 

Figure 5-4 Circular Ramp Structure 
The ramp is rotated 
about Y coordinate  
864 in. 
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Developed Elevation 

Developed elevations can simultaneously show multiple faces of the building in a single 
"unfolded" elevation view. To draw a developed elevation, from the menu select Draw> 
Draw Developed Elevation Definition, type a name for the developed elevation in the edit 
box in the Developed Elevations area of the form and click on ‘Add New Name’. Note: 
Make sure to set the 2D view-cutting plane to 300 in. This is located under the 
Options>Preferences menu. Next, in floor plan 8, click on the edge joints of the ramp 
until you’ve created a semi-circle shaped developed elevation. To view the elevation, 
click the View menu > Set elevation view and select the name of your Developed 
Elevation.  

Note: If the Options menu > Window command is set to two or more windows and those 
windows are set to Plan or 3D View, the location of the developed elevation is illustrated 
with a cyan line (default) in the Plan and 3D view windows.  

Curved Shear Wall Generation 

Now, we are interested in creating a curved shear wall surface around the edge of the 
circular ramp surface, which will run the full height of the structure. Go to the View>Set 
Named View menu to open the developed elevation. Next, select the Draw>Quick draw 
area button. Draw the shear wall over the entire length and width of the developed 
elevation. Click on a couple of wall elements and delete them. This will create an 
opening in the curved shear wall element. The 3-D structure should look like Figure 5-5: 

Figure 5-5 Circular Ramp Structure with Curved Shear Wall 
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EXAMPLE VI 2-D Frame Analysis 

Description 

This is a two-story frame analysis, subjected to lateral static loading. There are 2 bays 
with 12 ft. spacing in the X-Z plane.  The brace elements are W18x35 steel sections.  To 
see the system geometry, please refer to Figure 6-2: 

Significant Options of SAP2000 Exemplified 

� Tension/ Compression Limits

� Section Designer Module

� Quick Draw Brace Elements

� Nonlinear Load Cases

Computer Model Definition 

The 2-D frame is two stories high with a story height of 12 ft.  Each bay is spaced 24 ft. 
apart. Kip-inch-second units are used.  The modulus of elasticity used for steel is 29000 
ksi.   

Other parameters associated with the structure are as follows: 

Coefficient of Thermal Expansion  = 6.500E-06 
Poisson's ratio  = 0.3  
Shear Modulus = 11153 ksi 
Bending Reinforcement Yield Stress, fy = 60 ksi    

 Beam/Brace Properties: 

W18x35 Wide Flange Steel Section    

Building Loads: 

Lateral Load on Roof level  = 10 kips 
(Load applied in x direction) 
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To create this model, go to the File menu->New Model and select the 2-D frame option. Fill in 
the 2-D frame input as shown in Figure 6-1. Click OK and the model should appear on the screen.   

Figure 6-1 2-D Frame Input Data Form 

Drawing Brace Elements 

1. Click on the Quick Draw Braces button or use the Draw menu >Quick Draw
Braces command to display the Properties of Object form and switch to the
drawing mode. Select the Property (W18x35), Moment Release (Pinned) and
Bracing Type (X-bracing) from the form.

2. Click in a grid space, bounded by 4 grid lines, to draw a quick brace.

3. Click on all bays to create X-bracing in all 4 locations. The model should look
like Figure 6-2:
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Figure 6-2 Extruded View of 2-D Frame 

Load and Analysis Case Definition 

Go to Define>Load Cases and create a load case called LATX with an OTHER load type 
and a Self Weight Multiplier of 0.  Click Add New Case and click OK. 

Next, go to Define>Analysis cases and click on the LATX load case and select 
Modify/Show Case. Under the Analysis Type box, select the Nonlinear option. The 
analysis case data box should look like Figure 6-3: 

Figure 6-3 Analysis Case Data Form 
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Select the top left joint of the 2-D frame. Go to Assign>Joint Loads>Forces and select the 
LATX load case and assign a 10 kip load in the X-direction.  

Tension/Compression Limits 

An upper limit on the amount of tension and compression force supported by a 
frame/cable/tendon object can be assigned. This is used primarily to model tension-only 
cables and braces. The behavior modeled is nonlinear but elastic. For example, assume a 
compression limit of zero has been set. If the object tries to go into axial compression, it 
will shorten without any stiffness. If the load reverses, it will recover its shortening with 
no stiffness, and then engage with full stiffness when it reaches its original length. 

1. Click on the top left brace (top left to bottom right) in both bays. 
2. Use the Assign menu > Frame/Cable/Tendon > Tension/Compression Limits 

command to access the Frame T/C Limits form: 

� Tension Limit. Specify a tension limit by checking the Tension Limit box 
and entering a value that is zero or positive. 

� Compression Limit. Specify a compression limit by checking the 
Compression Limit box and entering a value that is zero or negative. 

Note: If zero is specified for both the tension and compression limit, the 
element will carry no force in a nonlinear analysis. 
 
Click on the Compression Limit option and enter a 0 kip limit. This 
makes these braces tension-only elements. 

Tension/Compression limits are nonlinear. This means: 

� They will be activated in a nonlinear static or nonlinear direct-integration time-
history analysis only. In general, use nonlinear analysis when 
tension/compression limits are present in the model. 

� If a linear analysis is performed using the stiffness at zero, the full axial stiffness 
(AE/L) of the element will be used as if there were no limits. 

� If a linear analysis is performed using the stiffness at the end of a nonlinear 
analysis, the axial stiffness will be zero or AE/L, depending on whether the object 
exceeded its limits at the end of the nonlinear case. 

  
This feature is useful for modeling cables and braces that can reasonably be represented 
by a single straight object when the analysis is focused more on the effect of the 



  “Optimized Modeling and Design of Structures using SAP2000”      

- 49 -

cable/brace on the structure than on the detailed behavior of the cable/brace itself.  

To model the deformation of the cable or brace in detail, break the cable/brace into 
several sub-objects, and use large-displacements analysis without compression limits. 
Under compression, the cable/brace will buckle out of the way in a more realistic 
representation of the true behavior.  

RESULTS 

We are now ready to run the analysis. Go to Analyze>Run Analysis and click Run Now.  
Click OK and the deflected shape for the DEAD load is shown.  We are interested in 
viewing the axial load diagram for the frame elements.  Under Display>Show 
Forces/Stresses>Frames, select the LATX load case and Axial Force component. The 
force diagram should look like Figure 6-4: 

Figure 6-4 Axial Force Diagram 

You can see the left brace forces in the top level are not taking any compression loads. 
The same braces in the bottom story are distributing compression loads.



“Optimized Modeling and Design of Structures using SAP2000” 

- 50 -



  “Optimized Modeling and Design of Structures using SAP2000”      

- 51 -

EXAMPLE VII Nonlinear Time History Analysis 

Description 

This example consists of 3 simple 2-D frames, subjected to a nonlinear Time History 
Analysis with the use of link elements. The first frame has no link properties assigned to 
it. The second frame contains damper link properties, as its lateral force resisting system. 
The third frame contains isolator link elements.  The frame geometry is shown in Figure 
7-1.

Significant Options of SAP2000 Exemplified 

� Time History Function Definition

� Time History Case Definition

� Damper/ Isolator Link Properties

� Creation of .AVI Files

� Time History Traces

� Response Spectrum Curves

Computer Model Definition 

These 3 frames contain one bay that is spaced 24 ft. apart. Each frame is 3 stories high. 
Each story level is 12 ft. in height. Kip-inch-second units are used.  The modulus of 
elasticity is 29000 ksi. A point mass of .25 is assigned to each joint in the X and Y-
directions.  

Link Element Definition 

Damper and Isolator Link Element 

Click the Define menu > Link Properties command to bring up the 
Define Link Properties form. Click the Add New Property button to 
access the NL link property data form.  Select the Damper or Isolator 
link element from the pull-down menu Enter the desired values for 
Mass, Weight, and Rotational Inertia. Note that the mass is for the 
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entire length of the element and is not mass per unit volume.  
Typically, link elements can have two sets of properties assigned to 
them:  

• Linear properties can be assigned to linear link elements only.
The linear property that you specify for each of the six degrees
of freedom of a linear link element is an effective stiffness.
This is simply a spring stiffness.

• Nonlinear dynamic properties, which are used for nonlinear
dynamic (time history) analysis. Note that you must have the
nonlinear version of SAP2000 to use the nonlinear dynamic
link properties.

The linear properties that you specify for each of the six degrees of 
freedom of all types of link elements other than linear link elements 
are an effective stiffness and effective damping. In such cases, the 
effective stiffness is, again, simply a spring stiffness. The effective 
damping specifies dashpot-type damping; it is not a specification of 
percent critical damping. 

In a linear analysis SAP2000 converts the specified effective damping 
for a link element to modal damping. It then adds the modal damping 
calculated for all link elements in the model that have effective 
damping specified to any modal damping already specified for the 
structure as a whole to get the final modal damping. SAP2000 reports 
this final modal damping in the printed analysis output for building 
modes. To get this output, click the File menu> Print Tables > 
Analysis Output command and check the Building Modal Info check 
box. 

Link Element Assignment 

Damper Link Element 

Go to Draw>Draw 2 joint link with the Damper property. Draw a 
diagonal line on every level of the middle frame.  

Isolator Link Element    

Go to Draw>Draw 1 joint link with Isolator property. Draw the link at 
the bottom story of the 3rd frame. 

The model should look like Figure 7-1: 
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Figure 7-1 Three-Frame Time History Model 

Time History Function and Case Definition 

In this example, we are interested in defining a pre-defined time history function 
from a text file. Go to Define>Functions>Time History and select Function from 
File.  Click the Browse button and select the time history text file. You can view 
time history graph by clicking on the Display Graph button. Fill in the Function 
File information: 
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Figure 7-2 Time History Function Definition 

Next, we define the Time History case data.  Go to Analysis Cases>Add New 
Case>Time History Cases. There are many options available including Number of 
Output Time Steps and Output Time Step Size. The output time step size is the 
time in seconds between each of the equally spaced output time steps. Do not 
confuse this with the time step size in your input time history function. The 
number of output time step size can be different from the input time step size in 
your input time history function. The number of output time steps multiplied by 
the output time step size is equal to the length of time over which output results 
are reported.  

We are interested in assigning the time history acceleration in the x-direction. The 
time history is a 12-second record, so enter 6000 time steps and time step size of 
.002 seconds. 
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Results 

Creation of .AVI video files 

After running the analysis (under menu>Analyze> Run Analysis), SAP2000 has 
the capability of creating an .AVI animation file. Use the File menu > Create 
Video> Time History Animation command to create videos in SAP2000 showing 
the movement of the structure during any time history analysis that has been run. 
Enter the input data for the video file:  

The Start Time, End Time, Time Increment boxes must be filled to create the 
video file. Use the default or define start and end times and time increments. The 
time increment controls how many different pictures (frames) of the deformed 
shape of the structure are created. For example, a time increment of 0.1 means a 
picture (frame) of the deformed shape is created for every one-tenth second of the 
time history.  

 Response Spectrum Curves 

After running a time history analysis, select one or more point objects and click 
the Display menu > Show Response Spectrum Curves command to access the 
Response Spectrum Generation form. Use the form to specify the appropriate data 
to plot the various response spectra. 

Important Note: The response spectrum that you plot using this command is 
based on a time history that you have previously run. It has nothing to do with 
any response spectrum analysis that you may have run. 

There are many options available when viewing Response Spectrum Curves. 
These include Axes, Damping and Period/Frequency definition. See Figure 7-3 
for a sample Response Spectrum Curve. 
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Figure 7-4 Response Spectrum Curves Plot 
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MESH TRANSITIONING AND COMPATIBILITY 
THE AUTOMATED LINE CONSTRAINT IN ETABS & SAP2000 

Ashraf Habibullah, S.E., President & CEO, Computers & Structures, Inc. 
M. Iqbal Suharwardy, S.E., Ph.D., Director of Research & Development, Computers & Structures, Inc.

In the application of the Finite Element Analysis Method, the most time consuming task 
is usually the creation and modification of the finite element mesh of the system. Not to 
mention the fact that creation of mesh transitions from coarse to fine meshes can be very 
tedious. Also matching up node points to create compatible meshes at intersecting planes, 
such as walls and floors can be very labor intensive. And even if the mesh generation is 
automated the mesh transitioning usually produces irregular or skewed elements that may 
perform poorly. This may have adverse effects on the design, especially in regions of 
stress concentration, such as in the vicinity of intersecting planes. 

The object based modeling environment of ETABS & SAP2000 clearly addresses these 
time-consuming shortcomings of the Finite Element Method. 

In the object-based modeling environment the Engineer generates the structural model by 
creating only a few large area objects that physically define the structural units such as 
wall panels, floors or ramps. The finite element mesh is not explicitly created by the user, 
but is automatically generated by assigning meshing parameters to the area objects. These 
parameters may include variables, such as mesh size, mesh spacing and mesh grading 
among others. With this capability the engineer can study the effects of mesh refinement 
by just defining a few control parameters. The new model with the desired level of 
refinement is thus created with minimal effort. 

If the meshes on common edges of adjacent area objects do not match up, automated line 
constraints are generated along those edges. These Line Constraints enforce displacement 
compatibility between the mismatched meshes of adjacent objects and eliminate the need 
for mesh transition elements. 

What makes this technology really powerful is that while making modifications to the 
model the Engineer need only be concerned about the few large physical objects of the 
structure. The modified finite element analytical model gets recreated automatically with 
any changes to the base objects.  

The following examples are designed to illustrate the power and practicality of this 
technology. 
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1EXAMPLE 1 

Simply Supported Plate (Mismatched Meshing) 

As illustrated in Figure 1, this is a model of a simply supported plate, which has been 
modeled in two different ways.  In one case the mesh is uniform across the plate and in 
the other case the mesh is fine on one half of the plate and coarse on the other half of the 
plate. In the latter case, an interpolating line constraint is automatically generated to 
enforce displacement compatibility between the adjacent halves of the plate where the 
mesh does mot match. As shown in the figure, correlation between the two models is 
very good. 

Matching 
Meshes 

(Uniform)

Mismatched 
Meshes

Fine Mesh Coarse Mesh

DEFORMED SHAPESSTRESS DIAGRAMS

Line   Constraint

Figure 1:  Simply Supported Plate with Mismatching Edges 
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EXAMPLE 2 

Curved Ramp Supported by Curved Wall 

This example, Figure 2, illustrates the use of Line Constraints to capture the interaction of 
a curved shear wall supporting a curved ramp. Notice that there are no joints at the points 
where the ramp element edges intersect the wall element edges. Displacement 
compatibility along the lines of intersection of the ramp and the wall is enforced 
automatically by the generation of Line Constraints along those lines. Notice how the 
application of Line Constraints allows the wall and ramp mesh to retain a simple 
rectangular (or quadrilateral) configuration. A conventional finite element model would 
be very irregular because it would need all the additional joints (and corresponding 
elements) to allow for the ramp element and wall element edge intersections. 

WALL & RAMP OBJECTS

INTERNAL MESHING

Figure 2:  Curved Ramp Supported by Curved Wall 
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EXAMPLE 3 

Floor Slab - Shear Wall Compatibility 

This example, Figure 3, illustrates a 3D Concrete Flat Plate Building with shear walls and 
an elevator core. Again, in this model, Line Constraints automatically appear at the lines 
where the   floor and wall objects intersect. This, of course, as in previous examples, will 
enforce displacement compatibility when mesh geometries do not match. As shown in the 
deformed shape of the Elevator Core, in many places the wall meshing does not match 
the floor meshing. All elements meeting at common edges, however, still show no 
displacement incompatibilities, even though the element nodes do not coincide. 

Figure 3:  Floor Slab - Shear Wall Compatibility 
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EXAMPLE 4 

Shear Wall – Spandrel Transition

This example, Figure 4, models a Shear wall – Spandrel System, illustrating mesh 
transitioning from the spandrel to the shear wall. Line Constraints are generated as 
needed in any direction. In this case the Line Constraints are vertical as well as 
horizontal. 

WALL OBJECTS INTERNAL MESHING

Figure 4:  Shear Wall - Spandrel Transition 
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