“From Start to Finish: Model, Design and Optimize a Multi-Story Concrete Structure using ETABS”

Presented by

CSI Educational Services

Seminar Topics

General Modeling

- Import DXF or DWG file from AutoCAD
- Model Creation (Concrete Beams, Columns and Floors)
- Meshing of Concrete Floor Systems
- Modeling of Pier and Spandrel Elements
- Modeling of Ramp Elements

Static and Dynamic Loading of Diaphragms

- Rigid, Semi-rigid, and Flexible Floor Diaphragms
- IBC 2003 Seismic Loads
- Mass Source Definition
- Auto-permutation of Wind Directions and Eccentricities
- Time History

Concrete Frame and Shear Wall Design

- Auto Loading Combinations and Design Groups
- Design for Torsion Effects in 3D Walls
- 2D and 3D Shear Wall Configurations
- Concrete Frame/ Shear Wall Design Code using ACI 2005

Model & Design of Concrete Floor Systems

- Flat Slabs, Foundation Mats, Spread & Combined Footings
- Cracked Slab Deflection Control

Drafting & Detailing of Concrete Structures (using SAFE Detailer)

- Drawing and Detailing of Complex Slabs
- Creation of Plans and Sections
- Reinforcing Details & Bar Schedules

Results: Creation of Output Reports for Submittal

- Detailed Concrete beam and shear wall output
- Added Design output to Database
Copyright

The computer program ETABS and all associated documentation are proprietary and copyrighted products. Worldwide rights of ownership rest with Computers and Structures, Inc. Unlicensed use of the program or reproduction of the documentation in any form, without prior written authorization from Computers and Structures, Inc., is explicitly prohibited.

Further information and copies of this documentation may be obtained from:

CSI Educational Services
Computers and Structures, Inc.
1995 University Avenue
Berkeley, California 94704 USA

Phone: (510) 845-2177
FAX: (510) 845-4096
e-mail: education@csiberkeley.com (for general questions)
e-mail: support@csiberkeley.com (for technical support questions)
web: www.csiedu.com
Table of Contents

Introduction 5

Part I – General Modeling 7

Part II – Static and Dynamic Loading of Diaphragms 23

Part III – Concrete Frame and Shear Wall Design 31

Part IV – Model & Design of Concrete Floor Systems 41

Part V – Drafting & Detailing of Concrete Structures (using SAFE Detailer) 45

Part VI – Results: Creation of Output Reports for Submittal 49

About the Speakers 53

Mesh Transitioning and Compatibility – The Automated Line Constraint 55
Introduction

This lecture is generally geared towards the intermediate user level of ETABS. However, if you have never used ETABS before, do not be set back. We have designed this course in such a way that even the inexperienced ETABS user will have no problem following along. The end-to-end example that we present will be drawn from scratch to exhibit the most general and common modeling techniques mentioned above.

The morning will be spent discussing general modeling techniques for concrete beams, columns, walls and floors. Part of the morning, as well as part of the afternoon will be spent on Concrete Frame and Shear Wall Design. We will finish the afternoon presentation discussing the design and detailing of concrete floor systems and output creation of reports for submittal.

We have chosen a very specific end-to-end example that we will describe in the presentation. In these seminar notes, you will find descriptions, computer model definitions, and results for the concrete structure. As we present the model, please feel free to follow along.
Part I  
General Modeling

Description

This is a thirteen-story concrete shear wall building that contains elevator cores at its north and south ends. A parking garage is located within the bottom five floors of the structure. Each parking floor is connected to the adjacent floors using ramp elements. The building is subjected to vertical static loading and computer-generated earthquake loading per the 2003 International Building Code. Automated wind loads are also applied to the structure per the ASCE 7-02 code. The building consists of concrete beams and columns along with a concrete deck on every level. Please refer to Figure 1 for a three dimensional view of the structure.

Figure 1 3-D View of Structure
Import Grid and Floors using DXF File

The grid definition for this model contains both Cartesian and cylindrical coordinate systems. The grid spacing in the X and Y directions are non-uniform. In this case, it is easiest to import an architectural grid from a .DXF file.

Click the File menu > Import > DXF File of Architecture Grid command to access the DXF Import form. Locate the filename/path of the .DXF file to be imported and click the Open button.

Use the drop-down boxes to select the DXF layer names that contains the lines and insertion points in the DXF file as the ETABS corresponding elements. For this model, we select the GRIDS layer and click OK. ETABS then imports the lines from any layer in the DXF file as ETABS grid lines. **Note: Make sure that the gridlines are drawn as a part of the GRIDS layer in the AutoCAD .dxf file.** In the Coordinate System box, choose the GLOBAL coordinate system for importing the file. Also select the units as Kip-Ft. Your grid system should look like Figure 2. If you want to import multiple grid systems, you could do so by reimporting another grid system to the same model.

![Figure 2 Architectural Grid](image)

Next, add the cylindrical coordinate system under Edit>Edit Grid Data>Edit Grid. Click the Add New System button and select the cylindrical option. Enter the values shown in Figure 3:
Click the Edit Grid button, then the Locate System Origin button. Enter the values shown in Figure 4. Click OK three times. **Note: Change the Grid ID’s to match Figure 5.**
Right now, the model consists of a single story. To insert the additional 11 stories needed for the completion of the grid, go to Edit>Edit Story Data>Insert Story. Enter the New Story Data and New Story Location as shown in Figure 6:

![Figure 6 Insert New Story Dialogue Box](image)

Your model now contains 12 total stories. As you can see in Figure 1, stories 7-12 are identical to each other; just as stories 6 are identical to each other. In this case, it would be beneficial to use the ‘Similar Stories’ option in ETABS. This means when you draw an object in plan, this object will be drawn on all stories that have been designated to be similar to that story. An assignment made to an object in a plan view also occurs at all levels designated as similar to the story. When an object is selected in plan view, objects of the same type in the same location at different story levels that are designated as similar to the story where the selection is actually made are also selected. If desired, change the similarity option in the drop-down box in the status bar at any time in a plan view. When you are in an elevation view or a three-dimensional view, the similar stories drop-down box displays the word "Inactive" to remind you that the feature is inactive in these views. When you switch from plan view to an elevation or three-dimensional view and then back to a plan view, ETABS will retain the similarity option that it last had in the drop-down box in the status bar for the previous plan view. To activate the Similar Stories option, go to Edit>Edit Story Data>Edit Story. Make changes as shown in Figure 7:
Model Creation (Floors/Walls, Columns and Beams)

As shown in Figure 1, this structure has 2 rounded terraces on the east and west faces that run from the 7th to the 12th floor. It would be difficult to accurately locate the points of these edges. To solve this problem, we will import the terraces and floor elements from a .DXF file. This command will import the floor elements to the model. Click the File menu > Import > DXF Floor Plan command to access the DXF Import form. Use the form to locate the filename/path of the .DXF file to be imported. Select the DXF layer names (Floors) that contain the area elements and insertion points in the DXF file. Make sure that you insert the floor at the 12th level. Your plan should look like Figure 8:

![Figure 7 Insert New Story Dialogue Box](image)
The darker floor elements represent the elevator cores and stair openings. Select the 5 area elements and go to Assign > Shell/Area > Opening to create holes in the slab. All floor elements were brought in as DECK elements. However, we want to use slabs for the floor elements in this model. To assign a Slab element to the floor, go to Assign>Wall/Slab/Deck sections. Select the SLAB1 property and click on the Modify/Show Section button. Select the CONC material type, enter an 8 in. thickness for both membrane and bending and click OK.

Make sure the ‘Similar Stories’ option is enabled in the bottom right corner of the screen and select all of the floor elements. Go to Assign>Wall/Slab/Deck Section and select the SLAB1 property and click OK.

Next, we want to replicate this 12th story down to the 6th story. In plan view, select all of the floor elements and go to Edit>Replicate>select the Story tab. Highlight the 6th-12th floors and click OK. You now have the entire slab elements defined at the top portion of the structure.
Now, we will manually draw the floor elements that occur at floors 6. These underground floors were not included in the .DXF file. Only the top floors (7-12) containing the terraces were created in AutoCAD. We will use the same SLAB1 property type as we did for floors 7-13. To draw the floor objects, go to the 6th floor plan view and click the Draw>Draw Area Objects>Draw Areas. Again, make sure the ‘Similar Stories’ option is enabled. Follow the floor plan as shown in Figure 9:

![Figure 9 Floor Slab Layout (1st-6th Stories)](image)

It is now time to add the shear walls to the structure. To define wall elements, go to Define>Wall/Slab Deck section. Select the WALL1 property and click on Modify/Show Section and enter a 12” thick section. There will be a detailed discussion about the meshing and defining of 2D and 3D Shear Walls in a later chapter.

Go to the 12th floor plan view and make sure the similar stories option is enabled. Also, turn on the Snap to Intersection option under the Draw menu. Go to Draw>Draw Area Objects>Draw Wall. Select the WALL1 property and carefully draw shear walls around the perimeter of the structure. Be careful to snap to all of the points on the outside of the terraces. At times, you may find it difficult to snap to the point that you want to. If you
To draw the elevator core walls, just as we did in the last step, go to Draw>Draw Area Objects>Draw Walls, select the WALL1 property and draw in the perimeters of the elevator cores just as you did for the walls on the perimeter of the building. To find the location of where to draw the elevator cores, please refer to figure 9 below.

To draw in the elevator openings, use the Draw>Draw Area Objects>Draw Areas command, and select the opening property. **The elevator cores and stair opening walls run the entire height of the building**. The model should now look like Figure 9:

![Wall Layout](image)

**Figure 9 Wall Layout**

The columns are the next elements to be modeled. Go to Define > Frame Section and from pull down menu, select add Rectangular. Give the column a section name of CONC24x36 and enter the values shown in Figure 10:
For cracked section analysis, you can click on the Set Modifiers button and change the scale factor of the Moment of Inertia. Modifiers can be used on shear walls as well. Modification factors can be defined as part of frame section properties \textit{and} assigned directly to line objects. Note that when modification factors are assigned directly to a line object that also has modification factors defined as part of its frame section properties, the two factors are multiplied. Therefore, it is intended that you specify modification factors using frame section property definition \textit{or} line object assignment, not both.

The first set of columns run the entire height of the structure. Go to the 12\textsuperscript{th} floor plan view and select the All Stories option in the bottom right hand corner of the screen. Activate the Draw menu > Draw Line Objects > Create Columns in Region or at Clicks (plan) command, and select the CONC24x36 property. There are two ways you can draw the columns: 1) left click at any location in a plan view to draw a column (vertical line object below), or 2) while working in plan view, depress and hold down the left button on your mouse and drag your mouse to rubber band a window around one or more grid line intersections then release. Columns (vertical line objects below) are automatically placed at each grid line intersection. NOTE: If you wanted to draw columns that didn’t fall on grid intersections, this can be done very easily using the Plan Offset X and Plan Offset Y options that are in the column drawing menu. The columns locations are shown in Figure 11.
There are additional concrete columns that are added at 6th story. These columns continue down to the 1st story and are used to support the underground parking garage and ramps. Use the draw commands discussed earlier to create the columns located on the lower levels. Please refer to Figure 12:

**Figure 11** Concrete Column Location (7th – 12th Stories)
Meshing of Concrete Floor Systems and Auto Line Constraints

During analysis, ETABS automatically meshes (divides) area objects that are assigned deck properties or slab properties with membrane behavior only. For this example, we are using slab type elements; therefore, we must mesh the slabs manually. First, select all of the floor elements (from Select>Area Object Type>Floors) and go to Assign>Shell/Area>Area Object Mesh Options. Click on the Auto Mesh Objects into Structural Elements button. Then, select the 1st three options. These options are 1) Mesh at beams and other meshing lines 2) Mesh at wall and ramp edges and finally 3) Mesh at visible grid lines. Meshing helps distribute loads realistically. In some cases you may not want ETABS to automatically mesh an area object into the analysis model.

For the curved terraces, the mesh may not be dense enough to ensure proper load transfer, which may result in some warning messages. To remedy this situation, select the curved terrace objects and select the 4th option, ‘Further subdivide auto mesh with maximum element size...’ and enter 42in. As you can see in Figure 13, the mesh is much more dense at the select locations. To view the meshing, go to View>Set Building View Options>and click on Auto Area Mesh.

Figure 12 Concrete Column Location (1st – 6th Stories)
In this model, all mesh points do not connect to the corner points of the terraces. In typical finite element analysis, shell elements are connected to other elements at corner points only. When an element does not frame into the corner point of a shell element, but instead frames into the edge of the shell element, no connection exists between the element and the shell element. ETABS is able to perform the analysis in this fashion. However, ETABS also has a very powerful feature called an Auto Line Constraint. The ETABS auto line constraints feature allows you to specify that elements framing into the edge of a shell element be connected to the shell element. ETABS internally takes care of connection between the elements by constraining points lying along an edge of the shell element to move with that edge of the element. This option is located under the Assign Menu> Shell/Area> Auto Line Constraint. By default, the Auto Line Constraint feature in ETABS is active (i.e. turned on). You have to flexibility to use the line constraint on the entire model or specific elements of the model. Additional information regarding the auto line constraint functionality in ETABS can be found at the end of this manual in a paper entitled “Mesh Transitioning and Compatibility using the auto line constraint in ETABS and SAP2000”.

Figure 13 Typical Mesh of Slab
Modeling of Pier and Spandrel Elements

Draw a wall on gridline G between gridlines 6 and 8. To do this, make sure you are in the plan view of Story 12 and the All Stories option is enabled in the bottom right hand corner of the screen. Go to Draw>Draw Area Objects>Draw Walls (plan). Click on grid intersections G8 and then G6.

The next step in this model is to mesh the elevator core wall to create door openings. There is a new drawing option in ETABS that allows the user to directly draw doors in an elevation view. First, we will need to create reference lines along the front of the elevator core (gridline 8). Reference lines are vertical lines at user-specified global X and Y coordinates. The reference lines are useful for snapping when drawing objects in elevation or plan view. Right click the mouse and select the Create Reference Lines on Plan option. Enter 2.5 feet in the Plan Offset X box. Click on the intersections of Gridlines 8E and 8F. Reference lines appear as points in plan view. Repeat this step using –2.5 ft in the Plan Offset X box and click on the Grid intersections 8F and 8E.

We need to assign reference planes to define top of the elevator doors. Reference Planes are horizontal planes at user-specified Z-ordinates. The main purpose of those planes is to provide a horizontal plane/line that you can snap to when drawing objects in elevation views. You can also view reference planes in a plan view. This option can be useful for adding mezzanine-type framing when you have not specified the mezzanine as a story level in the story data. In this case, the reference planes will signify the top elevation of the openings to be created in our shear walls. Go to Edit->Edit Reference Planes-> and enter elevations of 8ft, 20ft, 32ft, 44ft, 56ft, 68ft, 80ft, 92ft, 104ft, 116ft, and 128ft and click OK.

Use the Draw>Draw Areas>Draw Doors to create a door at the 1st level in between the assigned reference lines. Use the snap to lines and edges option to help create the door. You may need to use the reshape tool to make the door the correct size. When in reshape mode, click on an area object and a series of selection handles (squares that are the opposite color from the background color) will display at all corners of the area object, indicating that the program is in reshape mode and that the area object has been selected. Then move the area object by dragging or reshape it by dragging or specifying coordinates, as follows.

Once the door is drawn, select the door and go to Edit>Replicate>Story tab and select floors 2-12 and click ok. Use the replicate command to create doors on the other side of the elevator core. See Figure 14.

We want to mesh the walls so we can assign pier and spandrel labels to them. Select the entire wall on elevation 8 and go to Edit-Mesh shells and click on the Mesh/Quads/Triangles at Intersections with visible grid lines. You can delete the reference planes after you finish meshing the walls. Please refer to Figure 14:
Lastly, we need to replicate this entire elevator door mesh to elevation 2. (Be sure to first delete the existing elevator core shear walls at elevation 2). Select everything shown on elevation 8. Go to Edit>Replicate> Linear Tab. Enter –91ft in the dy box and click OK.

**Figure 14 Elevator Core Mesh**

A wall pier or spandrel can be made up from a combination of both area objects (shell elements) and line objects (frame elements). To get output forces reported for wall piers or to design wall piers, you must first define them. Define a wall pier by selecting all of the line and/or area objects that make up the pier and assigning them the same pier label. This can be done by going to Assign->Shell/Area->Pier Label or Spandrel Label. Assign Pier and Spandrel labels for the shear wall on Elevation 8.

It is important to note that when you assign pier labels, you must select all area objects that make up the pier and assign them the same pier label. However, when working with many wall piers *on the same story level*, use separate pier labels for every wall pier. If you do not do this, the shear wall design output will combine all wall pier forces with identical pier labels. See Figure 15.
Modeling of Ramp Elements

To draw ramp elements in ETABS is very simple. It is basically drawing a regular area element except that at least two of the corner points are located at different elevations. For this model, ramps are located on the underground parking levels, which are floors 6.

Go to the plan view of Story 6. The ramp will be located in between gridlines B and J. Make sure the Similar Stories option is enabled. Go to Draw>Draw Area>Draw Area Object and in a counter-clockwise manner, click on grid intersections J4 and then J6. Go down one story to level 5 (press the down arrow button at the top of the screen) and click on grid intersection B6 and then J4. All of the ramp elements from stories 6 will be created. By default, all ramp elements are given a SLAB1 property type.

If you turn off the wall, grid line, floor and opening properties in the model, you can see the ramps very well. (See Figure 16). To do this, go to View>Set Building View Options>and de-select the options you don’t wish to view.

Figure 15 Pier/Spandrel Labels
Figure 16 View of Ramp Elements
Rigid, Semi-Rigid and Flexible Floor Diaphragms

Assigning a diaphragm to an area object provides a diaphragm constraint to all of the corner points of the area object and to any additional point objects that are enclosed within the boundaries of the area object. This includes any points (joints) that are created as a result of automatic area object meshing.

**Important**: Diaphragms can be horizontal only. Thus diaphragm assignments are not applicable to wall-type and ramp-type area objects. They are applicable only to floor type area objects and to null-type area objects that happen to be in a horizontal plane.

In this model, we will assign semi-rigid diaphragms to all floor elements. This is a new option in ETABS. First, select all floor elements, and under the Assign> Shell/Area> Diaphragms option, click the Add New Diaphragm button to access the Diaphragm Data form.

Use the default name suggested in the Diaphragm edit box, or enter another name.

Specify the rigidity of the diaphragm by choosing the Rigid or Semi Rigid option. These options affect only the analysis of the model. If the rigid option is selected, a fully rigid diaphragm is assumed. If the semi rigid option is selected, the in-plane rigidity of the diaphragm comes from the stiffness of the objects that are part of the diaphragm. Select the Semi-Rigid option and click OK. You will now see the semi-rigid diaphragm has been assigned the all floors of the structure. The point where all of the lines of the diaphragm intersect is the center of mass. See Figure 17:
IBC 2003 Seismic Loads

To define earthquake and wind loads to the structure, you must go to Define > Static Load Cases. You can see that there are two default load cases already defined, DEAD and LIVE. Type EQX in the LOAD box, select a QUAKE type case, and then select the IBC 2003 seismic code from the pull down menu. Click Add New Load followed by the Modify Lateral Load button. The menu shown in Figure 18 will pop up.

Figure 17 Semi-Rigid Diaphragm Assignment
Figure 18 IBC 2003 Seismic Load Definition

Choose to specify the X or Y direction of the seismic loading, or to specify the direction with a percentage of eccentricity that is applicable to all diaphragms. Use the % Eccentricity edit box to specify a value for eccentricity. For this example, we will select to apply the loads in the X-dir.

Choose the Top Story and Bottom Story to specify the elevation range over which the automatic static lateral loads are to be calculated. By default the bottom story is the base of the building and the top story is the uppermost level of the building.

In most instances, specify the top story as the upper-most level in the building, typically the roof. The bottom level would typically be the base level. However, for this example, the building has several below-grade levels, and the seismic loads are assumed to be transferred to the ground at ground level, so it is best to specify the bottom story to be the 7th Story (level of the ground). Enter the Response Factor, Seismic Group and Seismic Coefficients as shown in Figure 18.
ASCE 7-02 Wind Loads and Auto-permutation of Wind Directions

Next, we will define the wind load cases to the model. Perform the same operation as discussed earlier to define a wind load case. This time we will apply a wind load in the Y-direction. Give the load case a name of WY, select a WIND load type and select the ASCE 7-02 code from the pull down menu. Click the Modify Lateral Load button to bring up the menu shown in Figure 19:

![Figure 19 ASCE 7-02 Wind Load Definition](image)

We have defined rigid diaphragms to this model, so select the ‘Exposure from Extents of Rigid Diaphragms’ option. The width of the diaphragm is calculated by the ETABS. To apply the wind load in the Y-direction, enter 90 degrees for the wind direction angle. The windward and leeward coefficients are defined as 0.8 and 0.5 respectively.

A new feature in ETABS allows the user to define one wind load case and the program will automatically create all of the remaining wind load cases. The ASCE 7-02 wind code must be used for this feature to be activated. The e1 and e2 values changes for each subsequent wind load case based on Figure 6.9 as well as the wind direction angles in the ASCE 7-02 code. A total of 12 different wind load cases will be defined. Enter all of the remaining Wind Coefficients shown in Figure 19.
Mass Source Definition

In ETABS, the user has the option of choosing one of three options for defining the source of the mass of a structure. Click the Define menu -> Mass Source command to bring up the Define Mass Source form. The following options appear on the form:

1. From Self and Specified Mass:

   Each structural element has a material property associated with it; one of the items specified in the material properties is a mass per unit volume. When the ‘From Self and Specified Mass’ box is checked, ETABS determines the building mass associated with the element mass by multiplying the volume of each structural element times it’s specified mass per unit volume.

2. From Loads:

   This specifies a load combination that defines the mass of the structure. The mass is equal to the weight defined by the load combination divided by the gravitational multiplier, g. This mass is applied to each joint in the structure on a tributary area basis in all three translational directions.

3. From Self and Specified Mass and Loads:

   This option combines the first two options, allowing you to consider self-weight, specified mass, and loads in the same analysis.

It is important to remember when using the ‘From Self and Specified Mass and Loads’ option, NOT to include the Dead Load Case in the ‘Define Mass Multiplier for Loads’ box. This will account for the dead load of the structure TWICE. For this example, we will choose the first option ‘From Self and Specified Mass’.

Time History Load Application

In this example, we are interested in defining a pre-defined time history function from a text file. Go to Define>Time History Function>Add Function from File. Click the Browse button and select the time history text file. The record we have selected is the 1940 El Centro earthquake record. This text file contains time and acceleration values for the specified earthquake. You can view time history graph by clicking on the Display Graph button. Fill in the Function File information:
Next, we define the Time History case data. Go to Define->Time History Cases-> Add New History. There are many options available including Analysis Type, Number of Output Time Steps and Output Time Step Size. The output time step size is the time in seconds between each of the equally spaced output time steps. Do not confuse this with the time step size in your input time history function. The number of output time step size can be different from the input time step size in your input time history function. The number of output time steps multiplied by the output time step size is equal to the length of time over which output results are reported.

We are interested in assigning the time history acceleration in the x-direction. The time history is a 12-second record, so enter 6000 time steps and time step size of .002 seconds. Enter a scale factor of 386.4 if you are using k-in units. Please see Figure 21:

**Figure 20 Time History Function Definition**
It is now time to run the analysis. First, go to Analyze>Set Analysis Options>click on Set Dynamic Parameters. You will see that by default there are 12 mode shapes that will be calculated. Change this value to 36 mode shapes and click OK. Go to Analyze>Run Analysis and the model will complete the analysis.

Figure 21 Time History Case Definition
Part III

Concrete Frame and Shear Wall Design

Auto Loading Combinations and Design Groups

For concrete frame and shear wall design, ETABS creates load combinations based upon the design code chosen and different load cases defined. To select a specific code for concrete design, go to Options>Preferences>Concrete Frame Design. For this example, choose the ACI 318-05/IBC 2003 design code. There are many design parameters that can be defined such as different PHI values, number of interaction curves and utilization factor limit. We will use all of the default values. Refer to Figure 22.

![Concrete Frame Design Preferences](image1)

**Figure 22 Concrete Frame Design Preferences**

The same can be done for concrete shear wall design. To select a specific code for shear wall design, go to Options>Preferences>Shear Wall Design. For this example, choose the ACI 318-02 design code. Again, there are different design parameters that can be defined. As was the case for concrete frame design, we will use all of the default values. See Figure 23:
Go to Design>Concrete frame Design> Select Design Combos. All of the available design load combinations are listed in the List of Combos list box. The design load combinations actually used in the design are listed in the Design Combos list box. Use the buttons on the form to move the load combinations into and out of the Design Combos list box to specify which combinations will be used during the design process. For our model, we have a very high number of design load combinations (78). This is due to the face that we defined 12 different wind load cases, an earthquake load case, as well as the default DEAD and LIVE cases.

Select a load combination and click Show to see how a specific load combination has been defined. The default concrete frame design load combinations have names like DCON1, DCON2 and so on. Refer to Figure 24.

Select a load combination and click Show to see how a specific load combination has been defined. The default concrete frame design load combinations have names like DCON1, DCON2 and so on. Refer to Figure 24.
The load combination scale factors will be affected if you go to Define>Special Seismic Load Effects and select Include Special Seismic Data Design. When this option is selected, the program calculated (or user defined) Rho factor and the user defined DL Multiplier are *automatically* applied to program default design load combinations for American codes (ACI, AISC, UBC) that include contributions from earthquake loads. Earthquake loads in this case are assumed to be all static loads of type QUAKE, all response spectrum, and all time history cases. These factors must be applied manually by the user for other design load combinations. ETABS calculates the Rho factor in accordance with Section 1617 of the 2000 International Building Code. The automatic calculation of the Rho factor depends on the floor area. ETABS calculates the floor area at each story level by summing the areas of the floor-type area objects at each story level. **Important Note:** The calculation of the Rho factor also depends on the ratio of the design story shear resisted by the most heavily loaded element in a story divided by the total story shear. This ratio is designated $r_{\text{max}}$. The value of $r_{\text{max}}$ can only be calculated if there is lateral load in the model. The Rho factor can only be calculated if $r_{\text{max}}$ is nonzero. *Thus, the Rho factor is only calculated when there is lateral load present in the model.* The calculated Rho factor along with intermediate results are output as part of the database displayed Building Output.

### 2D and 3D Shear Wall Configurations

In ETABS, you can define both 2D and 3D shear walls. As shown in Figure 15, the shear walls on the bottom two floors have been assigned pier and spandrel labels. This 2D shear wall configuration can be taken into an embedded utility in ETABS called Section Designer. Section Designer allows the user to define the reinforcement bar sizes and location within any shear wall.

For example, in Figure 15, you can see that the first floor contains two shear walls with a pier label P2. Go to Design>Shear Wall Design>Define Pier Sections for Checking and click on Add Pier Section. Click on ‘Start from Existing Wall Pier’ and select the story(2nd) and wall pier label(P2) from the drop-down boxes in the "Add Pier" area of the form so that ETABS knows which existing pier geometry to use. In cases where the top and bottom geometry of the pier are different, ETABS uses the geometry at the *bottom* of the pier. Click the Section Designer button to enter the Section Designer utility. The geometry of the pier is immediately displayed. See Figure 25.
Modify the geometry of the section. Also add rebar to the pier using the Draw menu commands. Right-click on the rebar to change the bar spacing and bar cover.

When the pier has been drawn, close section designer (click the Done button in the lower right-hand corner) and return to the Pier Section Data form and click the OK button to complete definition of the pier.

You can do the same thing for a 3D shear wall configuration. We must first assign new pier labels for define this 3D wall. Go to the plan view of the 12th story of the structure. Zoom in to the elevator core located at the south end of the building. Make sure the ‘One Story’ option has been enabled in the bottom right hand corner of the screen. Select all of the shear walls around the opening. Go to Assign>Shell/Area>Pier Labels and assign a pier label of P5 the walls and click OK. Your model should look like Figure 26:
Next, we can view this wall in Section Designer. Go to Design>Shear Wall Design >Define Pier Sections for Checking and click on Add Pier Section. Click on ‘Start from Existing Wall Pier’ and select the story(12th) and wall pier label(P5). See Figure 27.

Section Designer is a powerful utility that allows design of simple and complex cross sections of beams, columns and shear walls. Section properties, interaction surfaces and moment-curvature relationships can be displayed using the buttons on the top of the Section Designer screen.

**Figure 26 Pier Labels on Elevator Walls**

**Figure 27 3-D Shear Wall in Section Designer**
Concrete Frame/ Shear Wall Design

The design codes for the concrete frame and shear walls have already been defined. After running the analysis, the design portion of the program can be performed. You can choose to design for any one design code in any one design run. You cannot design some beams for one code and others for a different code in the same design run. You can however perform different design runs using different design codes without rerunning the analysis.

The analysis is based on these section properties, and thus, the design forces are based on these analysis section properties. The shear wall design section is completely separate from the analysis section. Piers can be assigned by selecting the pier element and then Design->Shear Wall Design->Assign Pier Sections for Checking. Three types of pier design sections are available. They are:

**Uniform Reinforcing Section:**
The Uniform Reinforcing Section pier may be planar or it may be three-dimensional. For shear design and boundary zone checks, the program automatically breaks the analysis section pier up into planar legs and then performs the design on each leg separately and reports the results separately for each leg.

**General Reinforcing Section:**
For flexural designs and/or checks, the user defines the pier geometry and the reinforcing in the Section Designer utility. For shear design and boundary zone checks, the program automatically breaks the analysis section pier up into planar legs and then performs the design on each leg separately and reports the results separately for each leg.

**Simplified T and C Pier Section:**
The simplified section is defined by a length and a thickness. The length is in the pier 2-axis direction and the thickness is in the pier 3-axis direction. You cannot specify reinforcing in a simplified section. Thus, the simplified section can only be used for design, not for checking user-specified sections.

To run the shear wall design, go to Design>Shear Wall Design>Start Design/Check of Structure. After you complete the Shear Wall Design portion of the program you can view the results in many different ways. Use the Design menu > Shear Wall Design > Display Design Info command to display on-screen output plotted directly on the model. All Shear Wall design output can be printed under File->Print Tables->Shear Wall Design. If desired, the screen graphics can then be printed using the File menu > Print Graphics command. Listed below are some of the design output options one can view:
- Simplified pier longitudinal reinforcing
- Simplified pier edge members
- Section Designer pier reinforcing ratios
- Section Designer pier D/C ratios
- Spandrel longitudinal reinforcing
- Shear reinforcing
- Pier demand/capacity ratios

When displaying design output information on the screen, right-click on the pier/spandrel to view more detailed information. See Figure 28:

![Figure 28 3-D Shear Wall in Section Designer](image)

Click on the Overwrites button to change the section from a General Pier section to either a Simplified T and C section or to a Uniform Reinforcing section.

The next step is to perform the concrete frame design. Use the Design menu > Concrete Frame Design > Start Design/Check of Structure. After the concrete frame design is completed, you can view many design results. These include:
- Longitudinal Reinforcing
- Shear Reinforcing
- Column P-M-M Interaction Ratios
- Joint Shear Capacity Ratios
- Rebar Percentage
- Torsion Reinforcing

Go to elevation 1 to view the concrete column design output:

![Concrete Frame Design Screen Output](image)

**Figure 29 Concrete Frame Design Screen Output**

By right clicking on any column element while viewing the design results, you can view specific details about the design. You can get information regarding the flexural design, shear design, interaction diagrams and joint shear. Click on the Summary button to get design values. See Figure 30:
**Figure 30** Concrete Frame Detail Summary

<table>
<thead>
<tr>
<th>Column Section Design Type</th>
<th>Units: Kip-in (Summary)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Level</td>
<td>4th</td>
</tr>
<tr>
<td>Element</td>
<td>C6</td>
</tr>
<tr>
<td>Location</td>
<td>144,000</td>
</tr>
<tr>
<td>Section ID</td>
<td>2A1036</td>
</tr>
<tr>
<td>Concrete ID</td>
<td>DGCH7B</td>
</tr>
<tr>
<td>L (ft)</td>
<td>144,000</td>
</tr>
<tr>
<td>W (ft)</td>
<td>20,000</td>
</tr>
<tr>
<td>D (ft)</td>
<td>26,000</td>
</tr>
<tr>
<td>dc (ft)</td>
<td>2,000</td>
</tr>
<tr>
<td>E (ksi)</td>
<td>30,000,000</td>
</tr>
<tr>
<td>Gc (ksi)</td>
<td>4,000</td>
</tr>
<tr>
<td>f (ksi)</td>
<td>50,000</td>
</tr>
<tr>
<td>fy (ksi)</td>
<td>60,000</td>
</tr>
<tr>
<td>LF (ksi)</td>
<td>0.600</td>
</tr>
<tr>
<td>N (ksi)</td>
<td>600</td>
</tr>
<tr>
<td>Overstrength Factor</td>
<td>1.25</td>
</tr>
<tr>
<td>Phi (Compression-Spiral)</td>
<td>0.700</td>
</tr>
<tr>
<td>Phi (Compression-Tied)</td>
<td>0.650</td>
</tr>
<tr>
<td>Phi (Tension Controlled)</td>
<td>0.900</td>
</tr>
<tr>
<td>Phi (Shear)</td>
<td>0.750</td>
</tr>
<tr>
<td>Phi (Seismic Shear)</td>
<td>0.600</td>
</tr>
<tr>
<td>Phi (Joint Shear)</td>
<td>0.050</td>
</tr>
</tbody>
</table>

**Axial Force & Biaxial Moment Design**

<table>
<thead>
<tr>
<th>Rebar Area (in²)</th>
<th>Pu</th>
<th>M2</th>
<th>M3</th>
<th>Minimum Pu</th>
<th>Minimum M2</th>
<th>Minimum M3</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.640</td>
<td>759,085</td>
<td>41,923</td>
<td>1078,610</td>
<td>1082,900</td>
<td>1276,570</td>
<td></td>
</tr>
</tbody>
</table>

**Axial Force & Biaxial Moment Factors**

<table>
<thead>
<tr>
<th>Major Bending</th>
<th>Delta M</th>
<th>Delta S</th>
<th>K</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.400</td>
<td>1.000</td>
<td>1.000</td>
<td>1.000</td>
<td>144,000</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Minor Bending</th>
<th>Delta M</th>
<th>Delta S</th>
<th>K</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.400</td>
<td>1.000</td>
<td>1.000</td>
<td>1.000</td>
<td>144,000</td>
</tr>
</tbody>
</table>

**Shear Design**

<table>
<thead>
<tr>
<th>Design Shear</th>
<th>Rebar Shear</th>
<th>Shear phi-Mc</th>
<th>Shear phi-Vs</th>
<th>Shear phi-Up</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.092</td>
<td>246.075</td>
<td>108.174</td>
<td>127.901</td>
<td>246.075</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Minor Shear</th>
<th>Rebar Shear</th>
<th>Shear phi-Mc</th>
<th>Shear phi-Vs</th>
<th>Shear phi-Up</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.055</td>
<td>155.487</td>
<td>108.257</td>
<td>52.150</td>
<td>155.487</td>
</tr>
</tbody>
</table>
Flat Slabs, Foundation Mats, Spread & Combined Footings

Now that the concrete frame and shear wall design has been completed, we can start on the foundation design. To do this, we can export floor slabs into the SAFE program.

The File menu > Export > Save Story as SAFE.f2k Text File command saves the specified story level as a SAFE.f2k text input file. You can later import this file/model into SAFE.

**Story to Export** drop-down list: Select the story level to export from the drop-down list. We are interested in selecting Story 7. There are a few options available when exporting the model. They are:

**Export Floor Loads Only**

**Export Floor Loads and Loads from Above**

**Export Floor Loads plus Column and Wall Distortions** - Only one check box can be checked at a time. We are interested in exporting floor loads and loads from above.

**Select Cases Button.** - Clicking this button displays the Select Loads form. Highlight the available loads to select or deselect them. Select the Dead and Live loads and click OK.

Next, open the SAFE program. Under the File menu, select the Import -> SAFE .f2k file. Select the .f2k file and click OPEN. The model should look like Figure 31:
Once the model has been imported, you do not have to perform any additional meshing. SAFE automatically meshes the slab internally. Go to the Options > Preferences > Design and select the ACI 318-02 design code. Under View > Set X Strip layer, you can see how the design strip have been created. You can change the design strip locations by simply redrawing them just like area elements.

**Cracked Slab Deflection Control**

Before we run the analysis and design, there is an option in SAFE that allows the user to define cracked slab deflection controls. Under the Analyze menu > Set Options, you will see a Normal and Cracked Deflection button. When the Analysis Type is Normal and Cracked Deflections, select the Interpolation Options for Slab Cracking Modifier (linear, Quadratic, Cubic, or 4th order). Accept the default Maximum Mesh Dimension or enter a new value by typing in the edit box. The Reinforcing Specification for Cracking Analysis form is used to specify the rebar to be used in the cracking analysis. Note that the spreadsheet in the middle of the form displays a strip ID, the X and Y starting points for the rebar, the width and length of the rebar, and the location (top or bottom) of the rebar.
The form has been designed to allow you to use the three options (Program Calculated, User Typical and User Other) in conjunction with one another to quickly tailor data entry to meet your specific needs. For example, if most, but not all, of the rebar can be calculated by SAFE, (1) click the Program Calculated button; (2) click the cell in the Reinf Type column for the row of data to be altered; (3) select the User Typical or User Other option; and (4) provide additional data input as described above for the User Typical or User Other options to modify those rebar that require specification other than the default. See Figure 32:

**Figure 32 Reinforcing for Cracking Analysis**

We are now ready to run the analysis and design for the slab. To do this, go to Analyze > Run Analysis. You will now see the deflected shape of the slab. To design the slab, go to Design > Start Design. The X-Strip rebar is now shown on the screen. Refer to Figure 33:
The model is in plan view showing the amount of steel required based upon the moment calculated. Go to Design > Display Design Info and the Slab Reinforcing dialogue box will appear. We are interested in viewing the Y-direction strip and determining the amount #6 bars required for the middle strip. After making these selections, the Slab Reinforcing dialogue box should look like Figure 33:

**Figure 32 X-Strip Reinforcing**

**Figure 33 Slab Reinforcing Dialogue Box**
Drafting & Detailing of Concrete Structures
(using SAFE Detailer)

Detailing of Complex Slabs/Creation of Plans and Sections

CSiDetailer prepares detailed engineering drawings in accordance with detailing codes, such as ACI-315-99, or by preferences set by the user. Those preferences may comply with building codes as well as be customized to meet additional requirements. CSiDetailer generates drawings from data generated through analysis and design completed using SAFE. The user is responsible for thoroughly examining and modifying the CSiDetailer-generated detailing and drawings. To facilitate further modification, CSiDetailer can generate DXF and DWG files of the drawings. Those drawings then can be opened and edited using AutoCAD or other CAD software.

The basic process for generating engineering drawings using CSiDetailer involves using the output generated by SAFE and then using a variety of forms to set options and preferences to guide the detailing process. After the Detailer is activated, various views are added to the drawings and arranged automatically. The views and preferences can be altered by the user as required. The drawings can then be printed to a printer, or exported in DXF or DWG format for use by AutoCAD. Make sure under Detailer>View Placement Options>select the ‘Scale to Fit Drawing’ option.

After setting the preferences, click the Detailing menu > Start Detailer command to start CSiDetailer and display the Detailing Status form. As the program details the model, progress will be shown on the Detailing Status form. When the detailing is complete, the program will automatically generate all possible drawings and add them to the project file. The main CSiDetailer window will display the File, Edit, View, Drawing, Tables, Options and Help menus. See Figure 34:
If the drawings need additional refinement, export them to an AutoCAD/CAD compatible format. Click the File menu -> Export Drawings command to display the Export Drawings form. Use the form to specify the format for the export and the drawings to be exported (current, all, or selected). The files may be exported in DXF or DWG file format.

Reinforcing Details and Bar Schedules

Under the Tables > Slab Rebar Schedule, you see rebar information, including bar marks, bar sizes, horizontal dimensions, cut lengths, total lengths of each bar type and their shapes, codes and graphical displays of all the bars for the detailed objects. The tables can be viewed and verified against the drawings but they cannot be edited. See Figure 35 to see this Table:
You can change slab detailing preferences under the options menu. Detailing preferences control how CSiDetailer completes detailing of the drawings based on the design model output. The preferences provide control over the design code, number format, the standard to be applied for rebar size and shape, and the rebar mark type for the various objects that are being detailed.

**NOTE:** It is highly recommended that the Slab Detailing Preferences be set before running the detailing of the model. Thus, use the *Detailing menu > Main Detailing Preference* command in SAFE to set the preferences and the *Options menu > Main Detailing Preferences* command in CSiDetailer to update or modify the preferences as needed. If the detailing has already been run and changes to the detailing preference are made in SAFE, when CSiDetailer is rerun, the program will prompt the user to (a) update the drawings in accordance with the preferences as specified in SAFE or (b) retain the previously set options and drawings.

Figure 36 displays the Detailing Preferences dialogue box:
Figure 36 CSI Detailer Slab Detailing Preferences
Detailed Concrete Beam and Shear Wall Output

When modeling large structures, it is very easy to for ETABS to create an enormous amount of output. ETABS has a feature that enables the user to select what specific output they need. The user can also select the elements (frames, walls, floor, etc) for which output to print.

We are interested in printing concrete frame design output for columns at the base of the structure. First, select a few columns for which you wish to see design output. Go to Print Tables>Concrete Frame Design>click on the Output Summary and Selection Only options and click OK. The information shown in Figure 30 will be printed for each column selected. You can organize output reports for submittal by selecting all controlling concrete sections and printing design output information for each of them.

We are now interested in printing shear wall design output for walls at the base of the elevator cores. We will print this information using two different methods. The first method is the same as described for the concrete frame design. Select the walls on the BASE level on elevation 8. Go to Print Tables>Concrete Frame Design and the dialogue box shown in Figure 37 will pop up.

![Print Shear Wall Design Tables](image)

**Figure 37 Print Shear Wall Design Tables**

Click on the Output Summary, Detailed Output, and Selection only buttons. This will print only the design output for the selected shear walls as shown in Figure 28.
Added Design Output to Database

Another way to extract output data from ETABS is to use one of the export options. Again, select the shear walls that you want information for and Go to Export>Save Input/Output as Access Database File. Check the check box associated with an item to include that item in the export. Expand the tree associated with a table type by clicking on the plus (+) symbol that precedes the table type name. Continue expanding the tree until the table appears. Make selections as shown in Figure 38 and then click the OK button. You will be asked to give the database a filename.

![Choose Tables for Display](image)

**Figure 38 Export Output to Access Database File**

To open the Access Database file, double-click on the file in the saved location. Once the file has been opened, double-click on the Pier Design Forces Table. A spreadsheet will appear that displays all of the design forces (P, V2, V3, M2, M3, etc) in a tidy format. See Figure 39:
### Pier Forces: Table

<table>
<thead>
<tr>
<th>Story</th>
<th>Pier</th>
<th>Load</th>
<th>Loc</th>
<th>P</th>
<th>V2</th>
<th>V3</th>
<th>T</th>
<th>M2</th>
<th>M3</th>
</tr>
</thead>
<tbody>
<tr>
<td>3RD</td>
<td>P1</td>
<td>DWAL26</td>
<td>Top</td>
<td>-274.962</td>
<td>18.4913</td>
<td>-0.2511199</td>
<td>4085.523</td>
<td>-26311.01</td>
<td>6811.3183</td>
</tr>
<tr>
<td>3RD</td>
<td>P1</td>
<td>DWAL26</td>
<td>Bottom</td>
<td>-282.162</td>
<td>18.4913</td>
<td>-0.2511199</td>
<td>4085.523</td>
<td>-26337.98</td>
<td>1083.648</td>
</tr>
<tr>
<td>2ND</td>
<td>P1</td>
<td>DWAL26</td>
<td>Top</td>
<td>-273.739</td>
<td>-1.2646566</td>
<td>-0.2305688</td>
<td>4067.36</td>
<td>-34380.22</td>
<td>197.5938</td>
</tr>
<tr>
<td>2ND</td>
<td>P1</td>
<td>DWAL26</td>
<td>Bottom</td>
<td>-260.928</td>
<td>-1.2646566</td>
<td>-0.2305688</td>
<td>4067.36</td>
<td>-34112.35</td>
<td>367.4676</td>
</tr>
<tr>
<td>3RD</td>
<td>P2</td>
<td>DWAL26</td>
<td>Top</td>
<td>-603.375</td>
<td>28.665565</td>
<td>-0.3261477</td>
<td>7070.863</td>
<td>-57925.7</td>
<td>-768.632</td>
</tr>
<tr>
<td>3RD</td>
<td>P2</td>
<td>DWAL26</td>
<td>Bottom</td>
<td>-603.374</td>
<td>28.665565</td>
<td>-0.3261477</td>
<td>7070.863</td>
<td>-57984.8</td>
<td>1062.337</td>
</tr>
<tr>
<td>2ND</td>
<td>P2</td>
<td>DWAL26</td>
<td>Top</td>
<td>-621.297</td>
<td>22.684516</td>
<td>-0.41234161</td>
<td>10946.06</td>
<td>-7184.96</td>
<td>-543.551</td>
</tr>
<tr>
<td>2ND</td>
<td>P2</td>
<td>DWAL26</td>
<td>Bottom</td>
<td>-635.636</td>
<td>22.684516</td>
<td>-0.41234161</td>
<td>10946.06</td>
<td>-71643.96</td>
<td>1820.333</td>
</tr>
<tr>
<td>3RD</td>
<td>P3</td>
<td>DWAL26</td>
<td>Top</td>
<td>-301.167</td>
<td>-4.371737</td>
<td>-0.27066566</td>
<td>565.5468</td>
<td>-34859.51</td>
<td>47.43781</td>
</tr>
<tr>
<td>3RD</td>
<td>P3</td>
<td>DWAL26</td>
<td>Bottom</td>
<td>-377.366</td>
<td>-4.371737</td>
<td>-0.27066566</td>
<td>565.5468</td>
<td>-34725.5</td>
<td>-429.6387</td>
</tr>
<tr>
<td>2ND</td>
<td>P3</td>
<td>DWAL26</td>
<td>Top</td>
<td>-385.574</td>
<td>25.41012</td>
<td>-0.2162708</td>
<td>5662.375</td>
<td>-44076.54</td>
<td>-1233.232</td>
</tr>
<tr>
<td>2ND</td>
<td>P3</td>
<td>DWAL26</td>
<td>Bottom</td>
<td>-392.774</td>
<td>25.41012</td>
<td>-0.2162708</td>
<td>5662.375</td>
<td>-44097.3</td>
<td>1208.139</td>
</tr>
</tbody>
</table>

**Figure 39** Access Database Output File
About the Speakers

ROBERT TOVANI, S.E.

Robert Tovani has twenty-five years of experience in structural analysis, design, project management, and construction administration. He is currently president of Engineering Analysis Corporation and an employee of Computer and Structures Inc. Mr. Tovani received his Bachelors and Masters of Science Degrees for the University of California, Berkeley and is licensed in California as a Civil and Structural Engineer.

Mr. Tovani has developed an extensive background in computer-aided analysis and design. His analysis background includes work on a variety of structures using linear and nonlinear analysis of new and existing structures in static and dynamic loading environments. He has developed computer models on high rise structures in excess of 100 stories and has provided design work on a variety of structural framing systems including base isolation and other complex framing systems. Mr. Tovani has been using the SAP and ETABS computer programs for over twenty-five years and has worked at CSI providing training and modeling assistance to CSI and Engineering Analysis clients.

ATIF HABIBULLAH, P.E.

Atif Habibullah has extensive experience using CSI products, having worked in CSI's Software Support department for five years. For the past two years, Atif has helped instruct engineers through CSI Educational Services training seminars. He has a strong background in modeling a variety of structural systems, solving special modeling problems and in the interpretation of analysis results. Prior to working at CSI, Atif worked at a leading design firm for 4 years using CSI products, particularly in the design of multi-story steel and concrete building structures such as hospitals, office buildings, towers, bridges, stadiums and dams.
MESH TRANSITIONING AND COMPATIBILITY
THE AUTOMATED LINE CONSTRAINT IN ETABS & SAP2000

Ashraf Habibullah, S.E., President & CEO, Computers & Structures, Inc.
M. Iqbal Suhaawardy, S.E., Ph.D., Director of Research & Development, Computers & Structures, Inc.

In the application of the Finite Element Analysis Method, the most time consuming task is usually the creation and modification of the finite element mesh of the system. Not to mention the fact that creation of mesh transitions from coarse to fine meshes can be very tedious. Also matching up node points to create compatible meshes at intersecting planes, such as walls and floors can be very labor intensive. And even if the mesh generation is automated the mesh transitioning usually produces irregular or skewed elements that may perform poorly. This may have adverse effects on the design, especially in regions of stress concentration, such as in the vicinity of intersecting planes.

The object based modeling environment of ETABS & SAP2000 clearly addresses these time-consuming shortcomings of the Finite Element Method.

In the object-based modeling environment the Engineer generates the structural model by creating only a few large area objects that physically define the structural units such as wall panels, floors or ramps. The finite element mesh is not explicitly created by the user, but is automatically generated by assigning meshing parameters to the area objects. These parameters may include variables, such as mesh size, mesh spacing and mesh grading among others. With this capability the engineer can study the effects of mesh refinement by just defining a few control parameters. The new model with the desired level of refinement is thus created with minimal effort.

If the meshes on common edges of adjacent area objects do not match up, automated line constraints are generated along those edges. These Line Constraints enforce displacement compatibility between the mismatched meshes of adjacent objects and eliminate the need for mesh transition elements.

What makes this technology really powerful is that while making modifications to the model the Engineer need only be concerned about the few large physical objects of the structure. The modified finite element analytical model gets recreated automatically with any changes to the base objects.

The following examples are designed to illustrate the power and practicality of this technology.
EXAMPLE 1
Simply Supported Plate (Mismatched Meshing)

As illustrated in Figure 1, this is a model of a simply supported plate, which has been modeled in two different ways. In one case the mesh is uniform across the plate and in the other case the mesh is fine on one half of the plate and coarse on the other half of the plate. In the latter case, an interpolating line constraint is automatically generated to enforce displacement compatibility between the adjacent halves of the plate where the mesh does not match. As shown in the figure, correlation between the two models is very good.

Figure 1: Simply Supported Plate with Mismatching Edges
EXAMPLE 2

Curved Ramp Supported by Curved Wall

This example, Figure 2, illustrates the use of Line Constraints to capture the interaction of a curved shear wall supporting a curved ramp. Notice that there are no joints at the points where the ramp element edges intersect the wall element edges. Displacement compatibility along the lines of intersection of the ramp and the wall is enforced automatically by the generation of Line Constraints along those lines. Notice how the application of Line Constraints allows the wall and ramp mesh to retain a simple rectangular (or quadrilateral) configuration. A conventional finite element model would be very irregular because it would need all the additional joints (and corresponding elements) to allow for the ramp element and wall element edge intersections.

Figure 2: Curved Ramp Supported by Curved Wall
EXAMPLE 3

Floor Slab - Shear Wall Compatibility

This example, Figure 3, illustrates a 3D Concrete Flat Plate Building with shear walls and an elevator core. Again, in this model, Line Constraints automatically appear at the lines where the floor and wall objects intersect. This, of course, as in previous examples, will enforce displacement compatibility when mesh geometries do not match. As shown in the deformed shape of the Elevator Core, in many places the wall meshing does not match the floor meshing. All elements meeting at common edges, however, still show no displacement incompatibilities, even though the element nodes do not coincide.

Figure 3: Floor Slab - Shear Wall Compatibility
EXAMPLE 4

Shear Wall – Spandrel Transition

This example, Figure 4, models a Shear wall – Spandrel System, illustrating mesh transitioning from the spandrel to the shear wall. Line Constraints are generated as needed in any direction. In this case the Line Constraints are vertical as well as horizontal.

Figure 4: Shear Wall - Spandrel Transition

BIBLIOGRAPHY


Computers & Structures, Inc Website: www.computersandstructures.com