Page tree
Skip to end of metadata
Go to start of metadata

This page is devoted to frequently asked questions (FAQ) related to import.

 

On this page:

How do I merge two models?

Extended Question: I have a substructure modeled in one file, and the superstructure in another. How do I merge the two such that they create a single model?

ANSWER: Models may be incorporated into a single file by opening the destination file, then import the .s2k text files through File > Import > SAp2000 .s2k Text File. Select the Add to Existing Model option to superimpose data onto the open model.

How do I import joint coordinates which are in CVS or TXT format?

Expanded Question: I would like to import, into SAP2000, a .csv or .txt file which contains comma-delimited joint coordinates. One point represents the member start node, then the next represents the end node. The file was generated using another software, and now I would like to use SAP2000 to analyze the structure. What is the best way to do this?

ANSWER: The best approach would be to use Interactive Database Editing in combination with an Excel spreadsheet. The steps are as follows:

  • Create a new model.
  • Use the Edit > Interactive Database Editing menu to select Expose All Input Tables, located on the right side.
  • Select Model Definition > Connectivity Data > Joint Coordinates > Table: Joint Coordinates to open the joint coordinates table.
  • Select OK to open the Interactive Database Editing - Joint Coordinates menu, then select To Excel, located on the right side.
  • Cut and paste the content of the CVS or TXT file into Excel, then organize the data into columns.
  • Return to the Interactive Database Editing - Joint Coordinates menu and select the From Excel option. This will transfer the data from Excel into SAP2000.
  • Update the SAP2000 model by selecting Apply to Model > Done.

Can I open my file in a previous version of the software?

ANSWER: Software changes made to the function of database tables prevent input files from being backwards-compatible. However, users may be able to import a model to a previous software version through the following process:

  • In the Program Control table (search for string "Program Control"), modify the file version (ex. 12.0.2 to 12.0.0).

 

Figure 1: Replacing the program version in the model text file

 

  • Open the lower version of the software and import the text file previously created.

Unless a database change was made between software versions which directly affects the storage of file data, this procedure should be effective so long as the software versions are relatively close in sequence.

Users should check the import log for error or warning messages, and carefully review the model once data is imported, to ensure successful transfer to the previous software version.

How can I ensure that an IFC file is valid prior to import to CSI software?

ANSWER: To validate an IFC file, users may first try to open the file using one of the IFC viewers listed on the iai-tech.org website. CSI recommends using the free CAD-DDS viewer.

How can I ensure that a CIS/2 file is valid prior to import to CSI software?

ANSWER: Users may upload a CIS/2 file to the online version of the NIST SteelVis tool to generate a VRML file in one of the following formats:

  • A text file in which the VRML text file can be downloaded to a local computer and viewed by such VRML viewers as FreeWRL.

  • A 3D interactive VRML model, which requires installation of the VRML plugin to the browser.

See Also